ISPConfig 2.0.9 released

Discussion in 'General' started by till, Sep 17, 2005.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 2.0.9 is available for download.


    - Added support for OpenSUSE 10.
    - Added support for Support for CentOS.
    - Updated ClamAV to 0.87.
    - index.aspx is now recognized so that no standard index page will be created if index.aspx is present.
    - Improved french translation and context-sensitive help (Thanks to Tribal-Dolphin).
    - Bugfix: Hosting Templates, SSI checkbox..
    - Bugfix: Bug fixed in Support system.



    Installation Instructions

    Download the ISPConfig-2.0.9.tar.gz from

    Installation on the shell as root User:

    tar xvfz ISPConfig-2.0.9.tar.gz
    cd install_ispconfig

    The installer detects automatically the installed
    ISPConfig version and performs an update.
  2. domino

    domino New Member

    Great to hear :eek:. Thanks for the upgrade :cool:
  3. mphayesuk

    mphayesuk New Member

    Hi how much of the original configuration process should we have to do again, ie asking me for my organisation details, ect.... like steps 1 to 8 from the original suse 9.3 perfect setup guide.

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This where not questions from the ISPConfig installer. Before the installer starts, the nescessary software in the latest versions is compiled and these questions are from the SSL-Certificate generation script.

    Do not do any steps in the perfect setup scripts again, just run the setup script and answer the questions.
  5. mphayesuk

    mphayesuk New Member

    So its ok if it asks me to define my hostname again and my sql server name with user name and password ect....

  6. falko

    falko Super Moderator ISPConfig Developer

    Yes, you don't have to deal with the Perfect Setup at all anymore, because your system is already set up! :eek: You just update ISPConfig.
  7. mphayesuk

    mphayesuk New Member

    Never mind I was getting a head of myself its all good and installed, thanks
  8. falko

    falko Super Moderator ISPConfig Developer

    No, if it's an update the installer won't ask you these questions (unless you did something terribly wrong...).
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    No, if it asks these questions the installer has not recognized your current installation. Do not remove or rename the /root/ispconfig or /home/admispconfig directories, otherwise the installer can not update your current installation.
    Last edited: Sep 17, 2005
  10. pontifex

    pontifex New Member

    that means, if mono is installed the application would work in the directory of the web?

    Is there a selection in the menu where to enable mono support, to be written into the vhost.conf of the apache server?


  11. dianer

    dianer New Member


    when I attempt to unzip the program, I get an error to the effect of child 1 missing or something like that. what is the issue with this, what am i doing wrong?
  12. falko

    falko Super Moderator ISPConfig Developer

    You mean you try to unzip it with a program like WinZip? This doesn't work, it's a tar.gz, not a zip file. Please have a look at the installation instructions:
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    No. Currently it is only the inde setting for mono.

    No. You can add the mono section in the Apache directives window.
  14. dianer

    dianer New Member

    ISPConfig 2.0.9

    When I type:
    tar xvfz ISPConfig-2.0.9.tar.gz
    I get 3 errors:
    gzip: stdin: not in gzip format
    tar: Child returned status 1
    tar: Error exit delayed from previous errors.

    Could I simply download the file to a cd and install it that way?

    If so, what's the command to mount a cd-rom drive and install from it?
  15. dianer

    dianer New Member

    ispconfig install

    I've burned the download to a cd and the cdrom drive is do i pull the files from the cd? :( I'm sorry I'm such an idiot....i'm really trying here folks.
  16. dranieri

    dranieri New Member

    Installation failure

    The command to install isp config is not working.
    Error message gzip: stdin: not in gzip format
    tar: Child returned status 1
    tar: Error exit delayed from previous errors.
    Have untared with 7 zip and burned to a CD and the exact same error message happens.
  17. domino

    domino New Member


    You do not have to burn to a media as it is not neccessary and a waste of time since the devs will update the script often in it's lifetime. If you do decide to burn it, the dev and mods on this site might not offer any support since this board is mainly for the How-To and ISPConfig.

    As to your problem with extracting the file, what type of internet access do you have? I downloaded the 19.9mb script and extracted just as the How-To explained it and it extracted fine. Maybe you are copy/pasting the wrong link at sourceforge?

    Now, go back to the tutorial and find the info that tells you how to uninstall/remove ISPConfig. There are more than a handfull of posts here that tell you also. then try the fallowing under root (each line is an individual command):

    tar xvfz ISPConfig-2.0.9.tar.gz 
    cd install_ispconfig 
  18. Ovidiu

    Ovidiu Active Member

    I could be wrong but it looks to me as if you are trying to tar -zxvf a file that you have already unzipped with 7 zip ?

    If you follow dominos advice all will be fine
  19. domino

    domino New Member

    And a special note. NEVER try to unzip/unarchive a unix archive with a 3rd party archive utility. It has proven many times that doing so will:

    a) screw up the directory structure
    b) screw up the privileges
  20. falko

    falko Super Moderator ISPConfig Developer

    I have an idea what you might have done so that you couldn't unpack the tar.gz. Is it possible that you downloaded ISPConfig with the following command:
    The is not the URL of the ISPConfig tar.gz, it's a page that redirects you to a page where you can choose from which server you want to download; so I guess you downloaded that page and tried to unpack it...
    You have to go to in your browser and then select where to download from.

Share This Page