ISPCconfig 2.x Ubuntu 8.04 SMTP send mail problem

Discussion in 'Installation/Configuration' started by faifas, Sep 26, 2008.

  1. faifas

    faifas New Member

    Hey dear fellows,

    I've came up with a new problem.
    I can receive e-mails with Mozilla thunderbird, but I can't send them.
    I've also installed UebiMiau webmail and sending mails through it works just fine.
    In Mozilla thunderbird, I've tried to edit my SMTP options to "TLS, if available", "TLS", "SSL".

    When I did SSL port was changed to something like 465. When trying to connect to that port I've got same error message that is:

    "The message could not be sent because connecting to SMTP server ... failed. The server may be unavailable or is refusing SMTP connections."

    So, I've changed SMTP port (in mozilla thunderbird) back to 25 and I still get same error.

    Tried telnetting to my server, everything seems to be fine.

    Telnet output:

    telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 vennezia.com ESMTP Postfix (Ubuntu)
    ehlo localhost
    250-vennezia.com
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH PLAIN LOGIN
    250-AUTH=PLAIN LOGIN
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN
    quit
    221 2.0.0 Bye
    Connection closed by foreign host.


    Do you have any ideas?

    Thanks in advance,
    Faifas
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    iptables -L
     
  3. faifas

    faifas New Member

    I did not enable firewall in ISPconfig and any other service, so iptables are empty.

    The output:

    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Still have no ideas what's going on.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    ?
    Any errors in the mail log?
    Do you use a personal firewall on your PC?
     
  5. soho

    soho Member

    When you use private IP is necessary to enable the firewall in ISPConfig.

    Management/Server/Services => firewall on
     
  6. faifas

    faifas New Member

    [email protected]:~# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost:mysql *:* LISTEN 22008/mysqld
    tcp 0 0 *:www *:* LISTEN 7437/apache2
    tcp 0 0 *:81 *:* LISTEN 11341/ispconfig_htt
    tcp 0 0 server.whatever.:domain *:* LISTEN 21454/named
    tcp 0 0 localhost:domain *:* LISTEN 21454/named
    tcp 0 0 localhost:ipp *:* LISTEN 4652/cupsd
    tcp 0 0 *:smtp *:* LISTEN 32365/master
    tcp 0 0 localhost:953 *:* LISTEN 21454/named
    tcp 0 0 *:https *:* LISTEN 7437/apache2
    tcp6 0 0 [::]:imaps [::]:* LISTEN 8308/couriertcpd
    tcp6 0 0 [::]:pop3s [::]:* LISTEN 8211/couriertcpd
    tcp6 0 0 [::]:pop3 [::]:* LISTEN 8144/couriertcpd
    tcp6 0 0 [::]:imap2 [::]:* LISTEN 8249/couriertcpd
    tcp6 0 0 [::]:ftp [::]:* LISTEN 32253/proftpd: (acc
    tcp6 0 0 [::]:ssh [::]:* LISTEN 5603/sshd
    tcp6 0 0 [::]:smtp [::]:* LISTEN 32365/master
    tcp6 0 0 ip6-localhost:953 [::]:* LISTEN 21454/named
    tcp6 0 1632 server.whatever.com:ssh ctv-213-164-120-57:1592 ESTABLISHED 17567/1



    Note: enabled firewall, still facing the same problem :|
     
    Last edited: Sep 28, 2008
  7. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in your mail log?
     
  8. faifas

    faifas New Member

    Well,

    my error log only whines about outdated ClamAV installation.

    I successfully connect to receive my messages, but logs say nothing about an attempt to send a message:

    Sep 29 19:13:18 Memphis imapd: Connection, ip=[::ffff:213.164.120.57]
    Sep 29 19:13:22 Memphis imapd: LOGIN, user=web1_aivaras, ip=[::ffff:213.164.120.57], port=[1356], protocol=IMAP

    It is weird that logs say Memphis even though hostname says otherwise

    [email protected]:~$ hostname
    server.whatever.com
    [email protected]:~$ hostname -f
    server.whatever.com

    Is it supposed to be this way?

    Another thing: my SSL to ISPconfig panel is broken (untrusted).
    Tried to create it again by falko's post, still the same problem.

    I believe these problems could be related, because I need to enable SSL setting when sending an e-mail.

    Another thing: I was listed in The Spamhaus Project - Policy Block List (PBL) - Email Policy System, but I've removed my server's IP and I still can't send e-mails.

    Any ideas?

    EDIT: by the way, I saw falko asking me if I was using antivirus. Yes, in fact on my laptop I've got avast installed, disabled it - still the same.
     
    Last edited: Sep 29, 2008
  9. falko

    falko Super Moderator ISPConfig Developer

    Can you try to use the server's IP address in your email client?

    Did you accept all default values when you created the certificate?

    What message exactly do you see in the browser? Is it Firefox 3? Then you may have to add an exception.
     
  10. faifas

    faifas New Member

    No, I did not accept default values, I've changed them to my own.
    Yes, I use Firefox 3 and I had to add an exception.

    Changed my SMTP server to an IP address, still the same, connecting forever.
     
  11. faifas

    faifas New Member

    Erm...

    that wasn't actually a problem. If I could send e-mails as I've said I would be blocked for open relay. I need to change SMTP server to my ISP's server, or add my home IP to my_networks duh.

    Anyway, thanks for everybody who were helping me.

    Faifas
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Did you enable "Server requires authentication" in your email client?
     
  13. faifas

    faifas New Member

    well, I do not use outlook, but thunderbird instead. Anyway I did check that my server requires authentication, but the problem is that I can't even establish a connection.
     
  14. falko

    falko Super Moderator ISPConfig Developer

    Where'S your server located? In a data center, or in your local network? If it's in your local network, how do you connect to it? By using a private IP or local hostname, or by using the public IP or the public hostname?
     
  15. faifas

    faifas New Member

    My server is not located in a datacenter or local network.
    It is in my other home, another city.

    When I connect to server I use it's public IP.
     
  16. falko

    falko Super Moderator ISPConfig Developer

    Ok, then make sure that your ISP doesn't block port 25.
     
  17. faifas

    faifas New Member

    It doesn't:

    [​IMG][​IMG]
     
  18. falko

    falko Super Moderator ISPConfig Developer

    No, you must ask your Internet service provider if they're blocking port 25. ISPConfig has nothing to do with this.
     
  19. faifas

    faifas New Member

    roger that, thank you for making this clear.
     

Share This Page