ispc3 client login

Discussion in 'General' started by mr_bo, May 17, 2009.

  1. mr_bo

    mr_bo New Member

    New install all up and resolving fine, just can't find the address for the client login, ispc2 was https://www.tld.com:81 but what is it for ispc3?

    Thanks in advance.
     
  2. till

    till Super Moderator

  3. mr_bo

    mr_bo New Member

    Thanks for that till, worked ok on an internal ip but the port mapping needed looking at and now all is fine.
     
  4. mr_bo

    mr_bo New Member

    Email/DNS problem

    Will carry on with this thread and hoping someone can help with an e-mail problem where some are getting through and some are not.

    The ones not getting through show this error:-

    Code:
    The reason for the problem:
    4.1.2 - Bad destination host 'DNS Soft Error looking up tld.com (MX) while asking recursive_nameserver0.parent. Error was: unable to reach nameserver on any valid IP'
    
    DNS check shows all ok:-

    Code:
    CheckDNS.NET is testing tld.com 
    
    
    CheckDNS.NET is asking root servers about authoritative NS for domain 
      Got DNS list for 'tld.com' from K.GTLD-SERVERS.NET 
      Found NS record: ns1.xxx.co.uk[xx.xx.xxx.xxx], was resolved to IP address by NS6.NIC.uk  
      Found NS record: ns2.xxx.co.uk[xx.xx.xxx.xxx], was resolved to IP address by NS6.NIC.uk  
      Domain has 2 DNS server(s)  
    
    CheckDNS.NET is verifying if NS are alive 
      DNS server ns1.xxx.co.uk[xx.xx.xxx.xxx] is alive and authoritative for domain tld.com  
      DNS server ns2.xxx.co.uk[xx.xx.xxx.xxx] is alive and authoritative for domain tld.com  
      2 server(s) are alive  
    
    CheckDNS.NET checks if all NS have the same version 
      All 2 your servers have the same zone version 2009051802  
    
    CheckDNS.NET verifies www servers 
      Checking HTTP server www.tld.com [xx.xx.xxx.xxx]  
      HTTP server www.tld.com[xx.xx.xxx.xxx] answers on port 80  
      Received: HTTP/1.1 200 OK (Server: Apache/2.2.3 (CentOS)) . . Welcome!. . . . . . . Welcome to . your website!. . . . . . For questions or problems please contact . support. .. . . . Powered by . ISPConfig. . .  
    
    CheckDNS.NET tests mail-servers 
      Domain tld.com has only one mail-server  
      Checking mail server (PRI=10) mail.tld.com [xx.xx.xxx.xxx]  
      Mail server mail.tld.com[xx.xx.xxx.xxx] answers on port 25  
      <<< 220 server2.xxx.co.uk ESMTP Postfix 
      >>> HELO www.checkdns.net 
      <<< 250 server2.xxx.co.uk 
      >>> MAIL FROM: <dnscheck@uniplace.com> 
      <<< 250 2.1.0 Ok 
      >>> RCPT TO: <postmaster@tld.com> 
      <<< 250 2.1.5 Ok 
      >>> QUIT 
      Mail server mail.tld.com [xx.xx.xxx.xxx] accepts mail for tld.com  
      All MX are configured properly  
    
    Not on any blacklist and didn't have this trouble using ubuntu/ispc2

    Any ideas?

    Thanks in advance.
     
  5. till

    till Super Moderator

    Please make sure that the dns servers listed in /etc/resolv.conf are valid an reachable by your server.
     
  6. mr_bo

    mr_bo New Member

    /etc/resolv.conf said:-

    nameserver (some random ip)
    nameserver (some random ip)

    changed to :-

    nameserver (my static ip)
    nameserver (my static ip)

    And re-booted.

    Is that correct?
     
    Last edited: May 18, 2009
  7. till

    till Super Moderator

    The nameserver must be a an accessible resolving nameserver. This is in almost all cases not your own IP. You will get the IP addresses of the nameservers from your ISP where you rented the server or the internet connection.
     
  8. mr_bo

    mr_bo New Member

    The ispc3 server is here at my home address on my static ip

    edit: have set the /etc/resolv.conf to the dns servers supplied by my isp
     
    Last edited: May 18, 2009
  9. mr_bo

    mr_bo New Member

    Right, after much digging I changed the /etc/resolv.conf to OpenDNS server settings and my router,then subsequently received about 15 known missing e-mails.

    Funny how I have been using the dns server supplied by my isp for almost a year and an ispc2 server 6 mths of that, then when I swap to ispc3 they dont work, tried pinging them from win cmd too and no response.
     
  10. till

    till Super Moderator

    Then the dns servers never worked. A ispconfig 2 instance can resolve domain names with bind as local resolver in case that the nameservers in the resolv.conf dont work while ispconfig 3 does not has a local resolver enabled by default.
     

Share This Page