ISPC move to port 80 on dedicated IP, but now ISPC complains Apache down

Discussion in 'Installation/Configuration' started by martinfst, Jan 11, 2007.

  1. martinfst

    martinfst HowtoForge Supporter

    Ubuntu 6.10, ISPConfig 2.2.9 mostly according to the Howto's.

    I allocated a specific IP to ISPConfig and used the tricks to have ISPConfig running on port 80. That works nicely, including Squirrelmail and phpMyadmin. https on port 80 on a dedicated IP (172.16.3.79).:)

    I added all IP's in the /etc/network/interface file:
    Code:
    auto lo
    iface lo inet loopback
    auto eth0
    iface eth0 inet static
            address 172.16.3.75
            netmask 255.255.255.0
            network 172.16.3.0
            broadcast 172.16.3.255
            gateway 172.16.3.254
    auto eth0:0
    iface eth0:0 inet static
            address 172.16.3.76
            netmask 255.255.255.0
            network 172.16.3.0
            broadcast 172.16.3.255
            gateway 172.16.3.254
    auto eth0:1
    iface eth0:1 inet static
            address 172.16.3.77
            netmask 255.255.255.0
            network 172.16.3.0
            broadcast 172.16.3.255
            gateway 172.16.3.254
    auto eth0:2
    iface eth0:2 inet static
            address 172.16.3.78
            netmask 255.255.255.0
            network 172.16.3.0
            broadcast 172.16.3.255
            gateway 172.16.3.254
    auto eth0:3
    iface eth0:3 inet static
            address 172.16.3.79
            netmask 255.255.255.0
            network 172.16.3.0
            broadcast 172.16.3.255
            gateway 172.16.3.254
    
    and added the 75-78 addresses in the panel under Management->Server->Settings in the textbox IP list. I entered the 79 address IP address in the hostname block. This results in ISPConfig complaining the webserver is not running. Writing this down, I come to think I need to remove the 79 address and just use e.g. 75 and remove from the IP List.

    Checking ...... Testing .......

    Nope, but the error became clear. Running manually the check script gives:
    Code:
    ~# /root/ispconfig/php/php /root/ispconfig/scripts/shell/check_services.php
    
    Warning: fsockopen(): unable to connect to localhost:80 (Connection refused) in /root/ispconfig/scripts/shell/check_services.php on line 92
    
    Warning: fsockopen(): unable to connect to localhost:80 (Connection refused) in /root/ispconfig/scripts/shell/check_services.php on line 92
    
    Any suggestion?
     
  2. martinfst

    martinfst HowtoForge Supporter

    Fixed by second look

    Have to answer myself ......

    As I changed apache to listen only on specific IP's, it's not listening on localhost. Adding 127.0.0.1 to /etc/apache2/ports.conf makes it all working again.
    Code:
    ~# cat /etc/apache2/ports.conf
    Listen 127.0.0.1:80
    Listen 172.16.3.75:80
    Listen 172.16.3.76:80
    Listen 172.16.3.77:80
    Listen 172.16.3.78:80
    Listen 127.0.0.1:443
    Listen 172.16.3.75:443
    Listen 172.16.3.76:443
    Listen 172.16.3.77:443
    Listen 172.16.3.78:443
    
    Great panel though. I should not want to do specific modifications ......
     
  3. horus.solaris

    horus.solaris New Member

    how?

    Hi martinfst !

    Is there a how-to or thread with those tricks how to get the ISPConfig running on port 80 ?

    Thx!

    HS
     
  4. martinfst

    martinfst HowtoForge Supporter

Share This Page