ISPc and Shinobi

Discussion in 'General' started by FredZ, Mar 29, 2022.

  1. FredZ

    FredZ Member HowtoForge Supporter

    Hello all
    Trying to get Shinobi working with ISPC
    Scenario:
    ISPC in its own proxmox VM.
    Shinobi is in its own proxmox VM. I did this because shinobi can be resource hungry and I didn't want it affecting anything in ISPc.
    Shinobi is setup on port 80
    I have created a domain and relavent DNS in ISPc
    I have setup proxy as follows in the Apache Directives section
    Code:
    ProxyRequests Off
    ProxyPreserveHost Off
    
    # avoid encoding of slashes
    AllowEncodedSlashes NoDecode
    
    # if https is used, make sure X-Forwarded-Proto is send
    RequestHeader set "X-Forwarded-Proto" expr=%{REQUEST_SCHEME}
    RequestHeader set "X-Forwarded-SSL" expr=%{HTTPS}
    
    ProxyPass /socket.io/ ws://xxx.xxx.xxx.xxx:8080/socket.io/ retry=0 timeout=60
    ProxyPassReverse /socket.io/ ws://xxx.xxx.xxx.xxx:8080/socket.io/
    ProxyPass / http://xxx.xxx.xxx.xxx:80/ retry=0 timeout=60
    ProxyPassReverse / http://xxx.xxx.xxx.xxx:80/
    I have also tried changing the port from 8080 to 80 in the above setup without any change.

    Issue: I can login to the shinobi consol using the local IP and everything operates as expected. However, when I login to the consol using the FQDN the consol is blank.

    I can login to the super user consol using the FQDN and it appears to function as expected.

    I have asked about this in the shinobicctv forums without success.

    Your comments would be most helpful.

    Regards

    Fred
     
  2. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    I am trying to get this correct, since you said your shinobi use port 80, does each vm has their own public ip? If only ISPConfig web server uses that port 80, then setting shinobi to use port 80 seemed redundant and my guess is, you should set shinobi to other non used port then you should try to see whether if proxy is set to this new port should work?
     
  3. FredZ

    FredZ Member HowtoForge Supporter

    Read the original message.
    I have tried using 80 and 8080 as ports.
    I suspect it is the way I have setup the proxy, but my very limited knowledge prevents me from knowing what I should be doing and how it should be done.

    Regards

    Fred
     
  4. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    May be it is your proxy settings but I am not sure perhaps because I haven't been using apache2 for more then 7 years, not to mention its proxy.

    However, as I read along about shinobi problem with reverse proxy, it seems like it hardly work on apache2 as I haven't seen any working suggestion except one that worked 3 years ago: https://www.reddit.com/r/ShinobiCCTV/comments/8mtdkw/comment/e91cu4l/

    Some say because of subfolders but work on subdomain but some said it works on nginx rather than apache2 and some say nginx reverse proxy definitely work with shinobi.

    So I don't personally know but I guess you have to do your own research more as I doubt it has to do with ISPConfig but more on shinobi itself i.e. how you set it up and its proxy.
     

Share This Page