ISP3 novice needs help

Discussion in 'Installation/Configuration' started by Spacestar54, Dec 3, 2017.

  1. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I just noticed there is three update-alternatives in the comments:
    Code:
    update-alternatives --config php
    update-alternatives --config php-fpm
    update-alternatives --config php-cgi
    Some posts suffer from removed newlines, which makes reading them a bit harder. Check You have issued all three update-alternatives, and all to the same PHP version. PHP 7.0 I assume is best for Debian Stretch. Then ISPConfig panel should work again.
     
  2. Spacestar54

    Spacestar54 Member

    I really don't understand this text.....
    php5-fpm.log --- WARNING: [pool web2] server reached pm.max_children setting (10), consider raising it
    --- WARNING: [pool web1] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), $
    auth.log --- pam_unix(cron:session): session opened for user root by (uid=0)
     

    Attached Files:

  3. Spacestar54

    Spacestar54 Member

    [email protected]:/# lsb_release -a
    No LSB modules are available.
    Distributor ID: Debian
    Description: Debian GNU/Linux 8.9 (jessie)
    Release: 8.9
    Codename: jessie
     

    Attached Files:

  4. Spacestar54

    Spacestar54 Member

    I'm stopping for a few hours, today we have Sint Nicolas day, a lot of packages to open and drink hot coco.
    I'll be back.... :>))
     
  5. Spacestar54

    Spacestar54 Member

    Missing something?? (see image)

    About the error:
    Dec 5 10:09:02 jos sessionclean[1851]: PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/20160303/mysqli.so' - /usr/lib/php/20160303/mysqli.so: cannot open shared object file: No such file or directory in Unknown on line 0
     

    Attached Files:

  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Use PHP 5.6 in the alternatives. That is what You used before installing extra PHP. Use
    Code:
    LANG=C update-alternatives
    to get english text.
     
  7. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Or maybe it was php 5.
     
  8. Spacestar54

    Spacestar54 Member

    Back to 5.6 and still no ISPConfig panel ... :>(
    Did, again, a lot of reading, not that easy for me in English!
    I learned new things (thanks) but I still need help.... ;>)
     
  9. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Check update-alternatives for all three are PHP 5.6. Check all the PHP-modules mentioned in Perfect Server Guide for Jessie are installed. For instance like this:
    Code:
    apt-cache policy php5.6-mysql
    Did You do something in addition to what the additional PHP versions installation guide told to do? For example, did You remove some packages?
     
  10. Spacestar54

    Spacestar54 Member

    What to do now?? (see image)

    No, I didn't remove anything... I even don't know how to do that.. :>)
     

    Attached Files:

  11. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Please use LANG=C before command you paste here. I do not understand dutch.
    Like so:
    Code:
    LANG=C apt-cache policy php5.6-mysql
    The error message you showed in #25 means php7.1-mysql is not installed. But if Your ISPConfig tries to use PHP 7.1 there is still some update-alternatives needed. Verify once more that default PHP is version 5.6, with the update-alternatives commands. Before this mishap You were running Debian Jessie which has PHP 5.6, so you must previously have had the necessary PHP modules ISPConfig needs. Verify they still are installed by comparing the PHP packages Perfect Server Guide Jessie tells to install to the packages currently installed.
    And now You should be able to use the
    Code:
    wget -q -O htf-common-issues.php "http://gitplace.net/pixcept/ispconfig-tools/raw/stable/htf-common-issues.php" && php -q htf-common-issues.php
    command to check for common issues.
     
  12. Spacestar54

    Spacestar54 Member

    OK, language is no English, the link didn't work yesterday, sorry... (see image)
    During the installation in 2016 it was PHP 5.6, I have only 2 update-alternatives working and both are PHP 5.6
    Can I put the script text (yes it works) here??
     
  13. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    How is the 3rd update-alternatives not working? Is that PHP module not installed?
    Read the script output. If you do not understand it you can post it to pastebin or here.
     
  14. Spacestar54

    Spacestar54 Member

    This is what I get:
    update-alternatives: error: no alternatives for php-fpm

    And the outcome of the hrt-common-issues.php:
    [email protected]:/home/jos# wget -q -O htf-common-issues.php "http://gitplace.net/pixcept/ ispconfig-tools/raw/stable/htf-common-issues.php" && php -q htf-common-issues.php
    PHP Fatal error: Call to undefined function mysqli_connect() in /home/jos/htf-com mon-issues.php on line 184
    PHP Stack trace:
    PHP 1. {main}() /home/jos/htf-common-issues.php:0
     
  15. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    It does look like you have not installed the needed PHP modules. Did you check the that? I'm at tablet computer now so can not help more.
     
  16. Spacestar54

    Spacestar54 Member

    How do I check this! Like apt-get update and apt-get upgrade?? This both options doesn't find missing modules??
     

Share This Page