ISP db records not deleted/mail not sent

Discussion in 'General' started by gilas, Jul 5, 2006.

  1. gilas

    gilas Member

    Hi folks,
    I discovered that if you delete a site configured through ISP admin panel the site will not be deleted.
    Infact you will find the site again in: /home/www directory. Probabilly this is correct, but looking the tables of ISP db the site is still present.
    Moreover I discovered why the system cannot send email to other domain, using sendmail or postfix.
    Infact before I created some sites to try ISPConfig (just I started using it) and deleted (debian sarge). But the file:


    contain again the wrong domain names. Before I used a wrong domain name yet existing.

    Then it happens that the system cannot send mails because the domain is defined under my machine and it believes to self-send the mail.

    The solution is to edit /etc/postfix/local-host-names and remove the domain names wrong.

    But I hope the ISPConfig staff can solve this problem and allow the admin user to *really* delete the sites yet erased...
  2. fobicodam

    fobicodam ISPConfig Developer ISPConfig Developer

    Did you try deleting the recicler bin? when you delete anything under ispconfig, its "marked" as deleted until you clear your ispc recicler bin..
  3. falko

    falko Super Moderator ISPConfig Developer

    fobicodam is right. Check your recycle bins in ISPConfig.

    If you don't want the system to handle emails for the domain, go to the Options tab of the domain and select "External Mailserver":

Share This Page