ISP config with mixed OS and DB versions

Discussion in 'Installation/Configuration' started by frankbootmaker, Jan 24, 2022.

  1. frankbootmaker

    frankbootmaker New Member HowtoForge Supporter

    Hi Everyone,

    I'm running an ISP Config system on Debian 9 with 3 nodes (1 master, 1 slave and 1 for secondary DNS).
    Recently one of my Customers requested me if I could set up a "latest version of everything (latest OS, latest MariaDB, Latest Php ...) node for him" and I wonder if I may try to have this also connected to the same master node, that is running on debian 9 and the 10.1.48 MariaDB version, or that won't work because of the significantly higher version of the satellite server and MariaDB compared to the master?

    Did anyone experienced / configured such or a similar scenario yet?
    Many thanks for your help / ideas / comments in advance! :)
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    The master and slaves must run the same version of ISPConfig, and debian 9 is still supported, so as long as you have the existing nodes on the latest ISPConfig version it should be fine. Plan on updating or replacing those old boxes soon though, they stop getting security updates this year, and I would expect to see debian 9 support dropped in the next major ISPConfig version (if not sooner).
     

Share This Page