ISP Config web-ftp

Discussion in 'Installation/Configuration' started by resnostyle, Sep 13, 2006.

  1. resnostyle

    resnostyle New Member

    Hello all,

    I was in the process of uploading my site using > Web-FTP/Password Protection of Directories (.htaccess/.htpasswd). When I went to do that it said "Could not connect to localhost". I know there is a problem in one of the config files.

    Thanks for your assistance.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Your FTP daemon must listen on localhost to if you want to be able to use the webftp in ISPConfig. Please post the output of:

    netstat -tap
     
  3. resnostyle

    resnostyle New Member

    (Not all processes could be identified, non-owned process info
    will not be shown, you would have to be root to see it all.)
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost.localdo:mysql *:* LISTEN -
    tcp 0 0 *:10000 *:* LISTEN -
    tcp 0 0 *:81 *:* LISTEN -
    tcp 0 0 *:smtp *:* LISTEN -
    tcp 1 0 localhost.localdom:smtp localhost.localdom:4839 CLOSE_WAIT -
    tcp6 0 0 *:imaps *:* LISTEN -
    tcp6 0 0 *:pop3s *:* LISTEN -
    tcp6 0 0 *:pop3 *:* LISTEN -
    tcp6 0 0 *:imap2 *:* LISTEN -
    tcp6 0 0 *:www *:* LISTEN -
    tcp6 0 0 *:ssh *:* LISTEN -
    tcp6 0 0 *:https *:* LISTEN -
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no ftp daemon started. Plese execute:

    /etc/init.d/proftpd start
     
  5. resnostyle

    resnostyle New Member

    okay we have arrived at the root of the problem.

    after issusing that command i recieved the following error message.

    Starting Proftpd ftp daemon: - Fatal: serverIdent: wrong number of parameters on line 26 of '/etc/proftpd.conf'
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post your /etc/proftpd.conf
     
  7. resnostyle

    resnostyle New Member

    Thank you very much till for your helping me.

    /etc/proftpd.conf
    Code:
    #
    # /etc/proftpd.conf -- This is a basic ProFTPD configuration file.
    # To really apply changes reload proftpd after modifications.
    #
    
    ServerName                      "Debian"
    ServerType                      standalone
    DeferWelcome                    off
    
    MultilineRFC2228                on
    DefaultServer                   on
    ShowSymlinks                    on
    
    TimeoutNoTransfer               600
    TimeoutStalled                  600
    TimeoutIdle                     1200
    
    DisplayLogin                    welcome.msg
    DisplayFirstChdir               .message
    ListOptions                     "-l"
    
    DenyFilter                      \*.*/
    
    DefaultRoot ~
    IdentLookups off
    ServerIdent on"FTP Server ready."
    
    # Uncomment this if you are using NIS or LDAP to retrieve passwords:
    #PersistentPasswd               off
    
    # Uncomment this if you would use TLS module:
    #TLSEngine                      on
    
    # Uncomment this if you would use quota module:
    #Quotas                         on
    
    # Uncomment this if you would use ratio module:
    #Ratios                         on
    
    # Port 21 is the standard FTP port.
    Port                            21
    
    # To prevent DoS attacks, set the maximum number of child processes
    # to 30.  If you need to allow more than 30 concurrent connections
    # at once, simply increase this value.  Note that this ONLY works
    # in standalone mode, in inetd mode you should use an inetd server
    # that allows you to limit maximum number of processes per service
    # (such as xinetd)
    MaxInstances                    30
    
    # Set the user and group that the server normally runs at.
    User                            nobody
    Group                           nogroup
    
    # Umask 022 is a good standard umask to prevent new files and dirs
    # (second parm) from being group and world writable.
    Umask                           022  022
    # Normally, we want files to be overwriteable.
    
    /etc/init.d/proftpd
    Code:
    #!/bin/sh
    
    # Start the proftpd FTP daemon.
    
    PATH=/bin:/usr/bin:/sbin:/usr/sbin
    DAEMON=/usr/sbin/proftpd
    NAME=proftpd
    
    # Defaults
    RUN="no"
    OPTIONS=""
    
    PIDFILE=`grep -i 'pidfile' /etc/proftpd.conf | sed -e 's/pidfile[\t ]\+//i'`
    if [ "x$PIDFILE" = "x" ];
    then
            PIDFILE=/var/run/proftpd.pid
    fi
    
    # Read config (will override defaults)
    [ -r /etc/default/proftpd ] && . /etc/default/proftpd
    
    trap "" 1
    trap "" 15
    
    thanks falko. corrected.
     
    Last edited: Sep 14, 2006
  8. falko

    falko Super Moderator ISPConfig Developer

    You only posted a part of your proftpd.conf. Please post the whole file.
     
  9. resnostyle

    resnostyle New Member

    Fixed above.
     
  10. falko

    falko Super Moderator ISPConfig Developer

    It must be
    Code:
    ServerIdent on "FTP Server ready."
    instead of
    Code:
    ServerIdent on"FTP Server ready."
    in /etc/proftpd.conf. Fix it and restart ProFTPd.
     
  11. resnostyle

    resnostyle New Member

    many thanks falko that was my error in configuration.
     

Share This Page