ISP Config - Update applications

Discussion in 'Installation/Configuration' started by bwragg, Jul 13, 2006.

  1. bwragg

    bwragg New Member

    I'm very interested in running ISPConfig on my server but have few questions about the upgrading of the applications that ISPConfig uses e.g apache, php, etc.

    From what I can understand when you download and install ISPConfig (e.g 2.2.3) it comes with the source code for apache 1.3.34, openssl-0.9.8a, php-5.1.4, etc and these get compiled and setup during the installation of ISPConfig. Correct?

    From following I think that mysql, bind and postfix don't come with ISPConfig but these must be installed prior to installing ISPConfig and then it detects these during install and configures itself accordingly. Correct?

    If that is correct then is it possible to install custom packages, for example apache 2.x and php 4.x instead of apache 1.3 and php 5.x.? If it is, how is this done? I'm thinking that I could switch the .tar.gz files in the compile_aps dir before installation of ISPConfig. Is that ok?

    Also, lets say in a few months a major security problem is found in the standard version of openssl that ispconfig installs and I want to upgrade this package, how do I do it? Is a standard openssl compile (./configure, make, make install) over the top of the existing package acceptable?

    Whats confusing me is the tutorial at installs apache2 and php via yum, then disables php and installs ISPConfig which doesn't use either the apache2 or the php just installed but rather Apache 1.x and php 5.x that comes in the ISPConfig tar ball.

    Thanks for your help.


  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, but they are not used for hosting your websites. The apache 1.3.x is only used to host the controlpanel on port 81 and the PHP is only used for the controlpanel application.

    You can use any apache and PHP version you like (ok apache must be > 1.2 and php must be at least php4 ;) ). ISPConfig uses always the apache and PHP that you installed from your linux distribution.

    Thats not nescessary. Just install all updates available from your linux distribution. The ISPconfig installer takes care for updates of its own (ISPCOnfig internal) packages.

    Thats a common misunderstanding as I explained above.

    ISPConfig uses the apache and pHP from your linux installation, the PHP and apache from ISPConfig are running only on port 81 to serve the controlpanel.
  3. bwragg

    bwragg New Member

    Thanks till, thats fantastic.

    So just to clarify, when you say:

    So I should update my servers applications via something like yum and when the next version of ISPConfig comes out it will upgrade it's own apache, openssl and php it uses for the control panel regardless of whats on my system?

    So as an example if I needed to run a ssl cert for a clients website I could install apache 2.x, the latest version of openssl (0.9.8b), mod_ssl and PHP 4, get my ssl key and it woult run fine? No conflict with the ISPConfig install?


  4. IntnsRed

    IntnsRed ISPConfig Developer ISPConfig Developer

    With ISPConfig you'll have two copies of Apache/PHP running:

    1) ISPConfig's copy which only runs on port 81 -- this runs your control panel. This is compiled on your box during the ISPConfig install. ISPConfig updates this itself.

    2) Your distro's regular Apache/PHP -- this runs your regular web sites. Your distro will update this. There are only minor changes to your regular distro's Apache config files. ISPConfig keeps the virtual domains in separate files which are then "Include"d into your distro's Apache config.
    Last edited: Jul 14, 2006

Share This Page