ISP Config, Postfix , Recieving Mail issue.

Discussion in 'Installation/Configuration' started by teknology, Mar 26, 2008.

  1. teknology

    teknology New Member

    I'm having a problem with my mail server. My setup is an Ubuntu 7.10 and completed the server with the help of The Perfect Server tutorial. For some reason i cannot recieve e-mails, and e-mails being sent is being bounced back. I've read through every forum and searched for answers but apparently my issue seems different from the others. Here is my E-mail that got bounced back.

    Code:
     This is the mail system at host server00.gnwebhosting.com.
    
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.
    
    For further assistance, please send mail to postmaster.
    
    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.
    
                       The mail system
    
    <GN1_tek@server00.gnwebhosting.com> (expanded from <tek@gfxncode.com>): unknown
        user: "gn1_tek"
    
    
    Final-Recipient: rfc822; GN1_tek@server00.gnwebhosting.com
    Original-Recipient: rfc822;tek@gfxncode.com
    Action: failed
    Status: 5.1.1
    Diagnostic-Code: X-Postfix; unknown user: "gn1_tek"
    
    
    Received: from imo-d22.mx.aol.com (imo-d22.mx.aol.com [205.188.144.208])
        by server00.gnwebhosting.com (Postfix) with ESMTP id 3F0E28BC64B
        for <tek@gfxncode.com>; Wed, 26 Mar 2008 16:37:26 -0400 (EDT)
    Received: from projecttek@aol.com
        by imo-d22.mx.aol.com (mail_out_v38_r9.3.) id r.d35.219ec3c7 (30739)
        for <tek@gfxncode.com>; Wed, 26 Mar 2008 16:37:17 -0400 (EDT)
    From: projecttek@aol.com
    Message-ID: <d35.219ec3c7.351c0dfd@aol.com>
    Date: Wed, 26 Mar 2008 16:37:17 EDT
    Subject: test
    To: tek@gfxncode.com
    MIME-Version: 1.0
    Content-Type: multipart/alternative; boundary="-----------------------------1206563837"
    X-Mailer: Unknown sub 34
    X-Spam-Flag: NO
    
    
    
    
    test
    
    This e-mail account is for a client account made by ispconfig. I fixed outgoing mails but incoming e-mails get bounced. I've been working on this for days any help is appreciated.
     
  2. teknology

    teknology New Member

    Update*

    I´ve found something interesting , in my mail bounceback it seems as though the server is looking for GN1_tek on m server domain name and not my clientś domain name. Hereś what my virtusertable looks like.
    Code:
    ###################################
    #
    # ISPConfig virtusertable Configuration File
    #         Version 1.0
    #
    ###################################
    tek@www.gfxncode.com    GN1_tek
    GN1_tek@www.gfxncode.com    GN1_tek
    tek@gfxncode.com    GN1_tek
    GN1_tek@gfxncode.com    GN1_tek
    tek@mail.gfxncode.com    GN1_tek
    GN1_tek@mail.gfxncode.com    GN1_tek
    test@www.gfxncode.com    GN1_test
    GN1_test@www.gfxncode.com    GN1_test
    test@gfxncode.com    GN1_test
    GN1_test@gfxncode.com    GN1_test
    test@mail.gfxncode.com    GN1_test
    GN1_test@mail.gfxncode.com    GN1_test
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
    From my understanding the server should be looking for the user(GN1_tek) in gfxncode.com instead of server00.gnwebhosting.com, the problem is i dont know how to change this.
    any help is appreciated.
     
  3. falko

    falko Super Moderator

    You're using capital letters in your usernames. Please change that, and it should work.
     
  4. teknology

    teknology New Member

    ispconfig does that automatically, i actually changed the user prefix too [DOMAIN]_ but it gives the XXXX.com , is there a way to just have the User prefix as the domain name without the .com?
     
  5. falko

    falko Super Moderator

    Change GN1_ to gn1_.
     
  6. teknology

    teknology New Member

    hey falko thanks a lot man. You should really write a book for linux newbies. The tutorials on this site are very accurate. Ispconfig does not use an installer for scripts like phpnuke,joomla, phpbb, etc.. , therefore i'm planning on using virtualmin. Would there be a how to with virtualmin or is it too easy to install?
     
    Last edited: Mar 28, 2008
  7. falko

    falko Super Moderator

Share This Page