ISP Config cron stopped working

Discussion in 'General' started by Jean-François Questiaux, Dec 11, 2020.

  1. In a multiserver setting, the cron queue is blocked and the changes are not carried to the other servers.
    All this was working untill the upgrade to 3.2.1 (from 3.1.5). I forced an update on the master server but that did not change anything.
    All servers are on Debian 10, but some are upgrades from Debian 8.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Thanks for the link.
    I followed the instructions but I don't see any error.
    The only message I receive is (same message on master and slave):
    DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    finished server.php.
    But the job queue is still stuck.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Then you have not enabled debug mode for this server on the master as described in the instructions.
     
  5. yes, it is enabled. On the master server, there are several messages but none looking like errors.
    On the slave server, I enabled it but this job is also stuck in the queue.
    However, soince I've done that, there are a few messages, but always the same (the one reported above).
     
  6. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    What are the messages? Removing the lock is normal, every run should end with that, the other messages should indicate what's happening, eg. maybe sql errors if the sql updates were incomplete.
     
  7. I ran some more tests and here is the situation:
    My setting is 1 master server and 4 slaves: 1 mail server, 1 db server, 1 web server and 1 web + db server
    Changes made on the master or the db server are working fine.
    Changes made on the 3 other servers are blocked in the queue and not carried over.
    I found these errors:
    • The mail server is on Debian 10, but upgraded from Debian 8. The PHP version (php -version) is still 5.6 from debian 8. Upgrading ISP Config gives the error: PHP Curl module not found.
    • On the two other servers, a ISP Config update (with or without --force) reports that the "Service 'web_server' has not been detected", even though all the sites hosted are working perfectly fine and this set up has been in place, and working perfectly, for months before updating to ISPConfig 3.2
    I guess intalling PHP 7.3 on the mail server will solve its issue, but I don't know why the web_server error occured, and how to fix it.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Install php curl module for the php version that you use now.

    Most likely you became root user the wrong way. Debian 10 requires is that you use:

    Code:
    su -
    command. if you would use only su without -, then su loads incomplete path variable. That's not ispconfig specific btw, its a change in the su version introduced with Debian 10 and we documented that new behavior in Debian 10 perfect server guide.
     
  9. Well, right on the nose about the root thing! i've been working with Debian 10 for a few months and never heard about this change before. That explains some of the errors I encountered from time to time.
    So the problems are solved for the 2 web servers.
    I'm running out of time to tackle the mail server today but it should go smoothly now.
    Thanks again for this great help.
     
  10. OK, I retake this post because I still have a problem with one of the slaves of my multiserver set up: all the changes made on this server (via the master) is blocked in the queue.
    Debug level is set to "Error" on both the master and the slave, but no error is reported on any of them.
    They are both updated to 3.2.2, services have been re-configured and the slave (an email server) is working fine on his own. It's just that I can't do anything on it from the master.
     
  11. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Change to debug log level and run server.sh manually in the slave and it should say what's going on.
     
  12. Yes according to the doc, it should say,... but it just says "finished server.php"
     
  13. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

  14. I did but the problem is the following: since the change of log level occurs on the master server and the issue is that these changes are not carried through the salve server, how can I "force" the change? Is there a way to manually do this directly on the slave server?
     
  15. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Are you sure this server is a slave of the master? Because if it can't connect, it should throw an error.
     
  16. Yes, it's been working for years now. I started to have issues since I upgraded to ISPConfig 3.2.
    When you say "it should throw an error", where would I see this error?
    Note that I have 2 other (slave) servers in the same setting and they are working fine.
     
  17. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Did you enter the root password for MariaDB when upgrading to 3.2? Did you try upgrading again? (you should update to 3.2.2 anyways as this fixes a security flaw)

    THe error should be thrown when running the server.sh script.
     
  18. Yes, the password was entered and I updated to 3.2.2 (even twice).
    "when running the server.sh script": on which server? Slave or Master?
    Is there a way to verify that the 2 servers can communicate?
     
  19. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    You have to set the debug level for the slave server and run the server.sh script on there. If it works without errors, the communication works.
     
  20. Thank you for your help but I think we are going in circle: I can't set the debug level from the master since the change is not applied to the slave.
    Is there another way (directly on the slave) to set this debug?
     

Share This Page