ISP Config BUG

Discussion in 'General' started by whitlebitle, Jan 21, 2008.

  1. whitlebitle

    whitlebitle New Member

    After I installed ISP config, everything is perfect except one thing:

    1. Make reseller
    2. Make client under that reseller
    3. Make site under that client
    4. Make FTP user for that site

    When this FTP user login through FTP to upload site, it can see whole root server?????? WTF??

    Is this bug, or this is standard feature?

    How to solve this?

    OS is Fedora 8 Running on Intel Machine.
     
  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Regarding the ftp thing, do you use vsftpd or proftpd?
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Neither nor. You just did not configure your FTP daemon correctly. You will have to enable chrooting for the users. To be able to give you a more detailed instructions, please answer Ben's question.
     
  4. whitlebitle

    whitlebitle New Member

    HMM...

    This is not dependable on FTP program.

    However I am using Total Commander, which is neither of the above.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Ben and I are talking about the FTP server program and not the client.
     
  6. whitlebitle

    whitlebitle New Member

    It is vsftpd..

    Can somebody help me with this ?
     
  7. jnsc

    jnsc rotaredoM Moderator

    Did you enable chrooting?
     
  8. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/vsftpd.conf?
     
  9. whitlebitle

    whitlebitle New Member

    Yes, I didn't enable chroot. After enabling it works perfect.

    Thank you very much.
     
  10. gluki

    gluki New Member

    Same problem with vsftpd

    But local users chrooted and anonymous is set to NO

    Can't access via control panel.
    ftp is accepting only local users and not users created with ispconfig.
    Why???

    ftp configuration file is set to - /etc/vsftpd.conf

    where is an errors? in ftp configuration or in the ispconfig somewhere?
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check your vsftpd.conf nad make sure that vsftpd authenticates against /etc/passwd and /etc/shadow as ISPConfig uses Linux system users.
     

Share This Page