ISP Config Backup

Discussion in 'General' started by nightdude, Nov 18, 2007.

  1. nightdude

    nightdude New Member

    I've been backing up my data by login into ISPConfig, Management, Backup with no problem at all on a Linux powered machine. Unzip it, looks like a database file.

    Today, I happened to be on a windows based machine (XP), followed the usual procedure, and ended up with a php file, when opened, is a black and white image of the ISPConfig Login Page. This was done repeatedly.

    Any idea why?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What browser are you using?
     
  3. nightdude

    nightdude New Member

    Backups

    In both cases, the Linux (Ubuntu - laptop) based machine and the Windows (XP Pro) machine, the back up was done with Firefox.

    So with the question you asked about which browser, I tried with Explorer on the Windows and it worked just fine. Never occurred to me to try Explorer - I never use it.

    I wonder why though?

    Thanks!!
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Hm, are there any errors in /root/ispconfig/httpd/logs/error.log?
     
  5. nightdude

    nightdude New Member

    Nothing.....

    :(
    Nothing at all in my error logs since November 1st, and that makes reference to [Hint: Stop button pressed in browser?!]. (Backup attempt on 14-18th)

    I tried to recreate problem today, it downloaded correctly on a windows machine.

    I dont know what happened or why..

    Night :confused:
     
  6. nightdude

    nightdude New Member

    It did it again

    Again, I ended up with a php file when performing a database backup.
    Using WIndows XP Pro, FireFox and Mass Downloader, which is the default down loader. No, no errors in log were generated.

    It does not happen if I use dTaOneClick or just Save to Disk, bypassing Mass Downloader. I guess there is something with Mass Downloader which does not interact well with ISPConfig. (And Yes, I have the Mass Downloader browser extension installed for FireFox - I know someone will ask)

    Night
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Maybe your mass downloader ignores the http headers that are sent by the script. The webbrowsers are able to read the correct file name from the headers.
     

Share This Page