ISP Config 3 wordpress always ask ftp

Discussion in 'General' started by lindu, Oct 10, 2019 at 6:32 PM.

  1. lindu

    lindu Member

    hi.
    i want add plugin from plugin wordpress online, but Always ask Ftp user and password. i add ftp user at admin ispconfig but failed
     

    Attached Files:

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Then you eithers elected a wrong php mode in website settings or missed to enable the suexec checkbox. The php mode for websites that run a cms system should be php-fpm or php-fcgi. Dn't use mod_php as this will not work for cms like wordpss which write files to the web directory.
     
  3. lindu

    lindu Member

    i change, but still ask ftp .
     

    Attached Files:

  4. lindu

    lindu Member

    include chown -R web8:client4 web/

    still error
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Wordpress will only ask for a FTP user you if you have chosen a wrong php mode or you missd enabling suexec or if your web files are owned by a wrong user. So check these three things again, there are no other options which might cause this.
     
  6. lindu

    lindu Member

    hi,
    i only enable fcgi and disable suexec, chown -R web1:client1 /var/www/web1/web like that

    how to solve this
     
  7. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Do not disable suexec. The screenshot you posted shows it is disabled. Till has written twice, in #2 and #5 that suexec must be on.
    Consult ISPConfig manual, page 125.
     
    till likes this.
  8. lindu

    lindu Member

    hi, if i click the link update plugin from dashboar, then wordperss themes(1).php will download using suexec, but if i go to install plugin , download to server and activate. success.
    thanks
     

Share This Page