ISP blocked port 25 !!

Discussion in 'HOWTO-Related Questions' started by mahmodsob, Jul 4, 2017.

  1. mahmodsob

    mahmodsob New Member

    I have a problem, my ISP reconfigure their servers so port 25 always closed, and while calling them they mentioned that they working on the problem but without a deadline for solving.
    While using telnet on port 25 OR 587 it says "421 service not available (configuration error, try again later)"

    All of us and our clients can't send mails, the in bounded mails arrives (mails on the same server), but out bounded mails failed (mails outside our servers)

    our servers has installed ISPConfig 3, postfix ... so what should i do to overcoming these problem !!
     
  2. Tuumke

    Tuumke Member

    Switch port 25 to something else? Or use SMTPS (port 587? used by submission)
     
  3. ahrasis

    ahrasis Active Member

    Talk to your ISP or use relay.
     
  4. sjau

    sjau Local Meanie Moderator

    Port 25 is necessary for email server to email server communication.
     
  5. mahmodsob

    mahmodsob New Member


    How to use relay !!
     
  6. mahmodsob

    mahmodsob New Member

    the problem not in my server , port 25 locked in ISP's server not my one .. so if i changed the port to any other it also won't work
     
  7. ahrasis

    ahrasis Active Member

    Change your relay settings accordingly in Server Config > Mail e.g. [smtp-relay.gmail.com]:587. You can also use the same for system mail in System Config > Mail.
     
  8. adamjedgar

    adamjedgar Member

    I know this is a late answer but for the sake of others with same problem, the answer is definately a mail service relay host using port 2525.

    Checkout Sendgrid...its a simple process to get working and is free for low usage.
     
  9. kwickcut

    kwickcut Member HowtoForge Supporter

    i have been using https://www.authsmtp.com/ for the past 8 years and it is very easy and cheap to use. i think i pay 35 bucks a year for 2 gigs of mail a month. they give great support and have a great write up for what you need to do. and they use port 2525
     
  10. Well guys,
    The problem is ISP blocked the port, most of the ISPs do that, due to spamming concern so simply use alternative port like 26 or use startls on port 587, configure your email server accordingly and you are good to go..
     
  11. adamjedgar

    adamjedgar Member

    If its a google cloud server, port 587 is also blocked.

    Sendgrid + port 2525 is a simple solution.
     
  12. That's true for clouded server which dont allow ports for emails.. You can simply go with alternate solution..
     

Share This Page