ISP and Amavis

Discussion in 'General' started by Ohmygaaad, Apr 7, 2016.

  1. Ohmygaaad

    Ohmygaaad New Member

    Hi all ,
    I have on my vps wich i did like the perfect server on Nginx , 3 websites and i receive lot of SPAM ... So i wanted to activate Spamassassin

    Its working well by the ISP interface , but i want to change :
    $final_virus_destiny », « $final_banned_destiny »,
    « $final_spam_destiny » « $final_bad_header_destiny

    i tried to modify them into 50-user or 20-debian_defaults , buts nothing append .

    i think that aconfiguration in these files is overwrite by ISPconfig on the interface .

    My spam tag is ISP interface is ***SPAM ISP*** and in 50-user its [SPAM] .

    always have SPAM ISP tag .

    if someone has a clue

    thanks a lot
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Use the policys in the interface to configure amavisd as it is a sql based configuration. all settings that area available in the spamfilter policys get read from there by amavis. settings that are not available in the policys get read from the amavisd config files. In any case, dont edit the 50-user file as your changes will get removed. Add a new file like 99-custom and add your changed there. do not forget to restart amavisd.

    Btw amavis IS SpamAssassin, so adding spamassassin a second time makes no sense as amavis loads the spamassassin internally and uses it to scan the emails. If you get too much spam, then you can lower the spam level in the policy that you use for this domain or mailbox.
  3. Ohmygaaad

    Ohmygaaad New Member

    hi !

    thank you for your respons !

    in ISP i chose : Uncensored with tag at 2 , tag2 at 6.31 , kill at 10 and dns 14

    so in my 99-custom , i put :

    $final_virus_destiny      = D_REJECT;  # (data not lost, see virus quarantine)
    $final_banned_destiny     = D_BOUNCE;   # D_REJECT when front-end MTA
    $final_spam_destiny       = D_REJECT;
    $final_bad_header_destiny = D_PASS;     # False-positive prone (for spam)

    my mail has :

    X-Spam-Flag: YES
    X-Spam-Score: 999.901
    X-Spam-Level: ****************************************************************
    X-Spam-Status: Yes, score=999.901 tagged_above=2 required=6.31

    But i still receive it while i changed to test : $final_spam_destiny = D_REJECT;

    can find a way to REJECT all spam :(
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Uncensored = no spam filter, so its no wonder that you get a lot of spam.

    Do not alter the amvis config file, then choose "Normal" policy and then lower the spam tag 2 level to 2. Do not reject spam as this will cause bounces as the mail is accepted in this pahse of the receiving process and you will get banned for backscatter if you jeject it. If you dont want to get the marked spam in the inbox, then set the kill level of the normal policy to 2 as well. Or enable the function to move marked spam into the junk folder automatically.
  5. Ohmygaaad

    Ohmygaaad New Member


    kill level at 2 do nothing when i receive an email with a score of 3 :s
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    And you have switched the mailbox from uncensored policy to the Normal policy? And you reverted all your changes in amavis config filesand restarted amavis?
  7. Ohmygaaad

    Ohmygaaad New Member

    yes i changed to normal

    btw , i tick to move Spam to Junk and its work by a different way :)
    . i think that i changed some files in amavis thats wh its not working what you said.

    i thnk that i changed some settings in config files , was my first VPS without bachup of config file ....

    thanks you for your time ! ISP is great !!

Share This Page