Isconfig3 Amavis: All email marked as spam

Discussion in 'Installation/Configuration' started by David Tham Wei Fan, Dec 12, 2017.

  1. David Tham Wei Fan

    David Tham Wei Fan New Member HowtoForge Supporter

    All my email are being marked as spam, the only way for me to receive the email is to turn on "Spam lover" for my default policy, apply at domain level. After doing that when I do receive the email I can see that all of them having X-Spam-Flag: YES alto having a very low score (below 3)

    See one of the example:
    Return-Path: <[email protected]>
    Delivered-To: [email protected] Received: from localhost (localhost [])
    by dvlmailvpapp01.dave-vlab.local (Postfix) with ESMTP id CA8B1A7872
    for <[email protected]>; Tue, 12 Dec 2017 10:28:50 +0100 (CET)
    X-Virus-Scanned: Debian amavisd-new at dvlmailvpapp01.dave-vlab.local
    X-Spam-Flag: YES
    X-Spam-Score: 1.284

    X-Spam-Level: *
    X-Spam-Status: Yes, score=1.284 tagged_above=0 required=0
    tests=[HTML_MESSAGE=0.001, RDNS_NONE=1.274, SPF_PASS=-0.001,
    T_KAM_HTML_FONT_INVALID=0.01] autolearn=no autolearn_force=no

    My default policy was created new named as "Typical" not using any of the template (Non-paying, Uncensored, Wants all spam, Wants viruses, Normal, Trigger happy, Permissive) The Spam Tag level, Spam tag2 level and kill level are set to 3.5, 7, and 10, respectively.)

    So I don't understand how come all of the email having lower score than defined in the policy yet still get marked as SPAM. Please help.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    That's a problem in either amavis or perl which started to tread database column types differently and we implemented a workaround for that in ISPConfig some time ago.

    Which ISPConfig version do you use? If you haven't updated to the current version 3.1.9 yet, then install the update and test again.
    David Tham Wei Fan likes this.
  3. David Tham Wei Fan

    David Tham Wei Fan New Member HowtoForge Supporter

    Yes i updated the ISPConfig to latest version 3.1.9 and did some tweak to smtpd_helo_restrictions setting in postfix, now all are good! Thank you very much!

Share This Page