Is suphp working with ispconfig version 2.2.17

Discussion in 'Installation/Configuration' started by zanard, Oct 7, 2007.

  1. zanard

    zanard New Member

    I want to execute PHP scripts with the permissions of their owners.
    I tested suphp configuration on my server but something goes wrong... so I have few question before I continue to find solution for create/modify files with php...

    - Is suphp working with ispconfig version 2.2.17?
    - Is possible to use scripts without extension as php scripts, like "index" instead of "index.php" after suphp is activated?
    - I find out that under cgi setting you don't have possibilities to use .htaccess directives like "RewriteRule, is it right?

    At the moment I have in .htaccess file following lines to activate all scripts which don't have extension as php script.

    RewriteEngine On
    RewriteRule ^[^.]+$ - [T=application/x-httpd-php,L]

    or is there better solution to do that.
    Last edited: Oct 7, 2007
  2. Hans

    Hans Moderator ISPConfig Developer

  3. zanard

    zanard New Member

    use scripts without extension as php scripts when php is installed as cgi

    Thank you for your answer.
    But still I need solution other questions/problems... I want to use files without extension as php scripts as mentioned first post but when I made suphp installation rewrite rule in apache directive not working anymore or I made some mistake in configuration.
    Maybe some smart guy share hes own experience how to solve this problem.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    AsHans said, ISPConfig supports SuPHP. Have a look at the error.log file in the log directory of the website to see if your rewrite code causes some errors. Also make sure that your rewrite code uses the same application type that is registered for SuPHP.
  5. zanard

    zanard New Member

    session problem

    Thank you Till, your answer helps me to solve my problem. I changed application type and everything works except sessions. php sessions don't work correctly.

    Found mistake, wrong permissions...
    Last edited: Oct 8, 2007

Share This Page