Is it possible to re-enable CGI as an option in ISPConfig 3.1?

Discussion in 'Developers' Forum' started by winsbury, Sep 12, 2019.

Tags:
  1. winsbury

    winsbury New Member

    I have a large legacy website that ran perfectly on our old ISPConfig 3.1 Centos 6.6 server but doesn't work on our new Ubuntu 18.04 ISPConfig 3.1 machine

    The Perl/CGI elements are failing to execute correctly and I think it may be because in the Domain settings on the new server there is no longer an option for CGI, instead only Fast-CGI , Mod-PHP and PHP-FPM are available.

    Is it possible to re-enable CGI as an option ?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The CGI option is still there, t#s a checkbox in teh website settings. You seem to mix up PHP in CGI mode with CGI here, the PHP CGI mode which is not available anymore by default is not related to Perl.
     
  3. winsbury

    winsbury New Member

    Thanks Till.

    I am at a loss then, it is the only setting I can see between the two servers which differs. I have not ( cannot ) modify or debug the scripts as they are buried in part of a commercial package but it now fails to pass pre-installation checks due to a an scripting error ( no details are given.)

    Yes those boxes are ticked: CGI , Perl

    I have tested some basic CGI scrips .pl and they work okay although there is a minor version upgrade from the old server.

    Any other ideas gratefully received
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You can enable PHP CGI mode again under System > server config, but I don't think that it will make any difference. The script vendor support might help you with the problems.
     
  5. Jesse Norell

    Jesse Norell Well-Known Member

    Perhaps you are missing some required perl modules? Check the software requirements and also check logs for errors. I setup I think 2 perl-based sites on ISPConfig which were pretty simple, but still needed a few modules installed to function.
     
  6. winsbury

    winsbury New Member

    Ah - missing Perl modules, I hadn't thought of that !... will try . Ive re-enabled in config too. fingers crossed.
     
  7. winsbury

    winsbury New Member

    No joy I am afraid. I suspect some code is broken by the slightly later Perl version but that sucks becuase there is no support available for the package any longer.
     
  8. Chris_UK

    Chris_UK Member HowtoForge Supporter

    You will be glad to know that you can have multiple versions installed at one time. I do this with different java versions because of an application that requires it.

    What you will be searching for here is how to define the perl version in the application. or, if its the only perl application you have running on the server, you just set that version as default. Something akin to dpkg-reconfigure-defaults -perl and selecting the appropriate version for your application. Google will be a better source than me, ive only had to do this once and then I ended up just defining it in as a java cli option.

    A short search quickly yields results, check this SO link for multiple perl versions: https://stackoverflow.com/questions/1289564/how-should-i-install-more-than-one-version-of-perl
     

Share This Page