Is dns right?

Discussion in 'General' started by Niels, May 18, 2010.

  1. Niels

    Niels New Member

    I have the domain jule-indsamling.dk but it seems that my nameserver (latest version of ispconfig) dont work as it should...

    my nameserver is ns1.netopcom.dk

    How can I see whats wrong with it?
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    To test the nameserver, you can use this command on the shell:

    dig @ns1.netopcom.dk jule-indsamling.dk
     
  3. Niels

    Niels New Member

    It returns this (its running on Debian 5)


    ; <<>> DiG 9.5.1-P3 <<>> @ns1.netopcom.dk jule-indsamling.dk
    ; (1 server found)
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached

    Im lost here :(
     
  4. mhpcomputerservices

    mhpcomputerservices Member HowtoForge Supporter

    It would appear that the DNS server is not running on your server.

    DNS server ns5.gratisdns.dk[85.17.221.46] is alive and authoritative for domain jule-indsamling.dk
    DNS server ns3.gratisdns.dk[194.0.2.6] is alive and authoritative for domain jule-indsamling.dk
    Error fetching SOA from ns1.netopcom.dk [86.58.173.14], request timed out. Probably DNS server is offline.
    DNS server ns4.gratisdns.dk[208.43.238.42] is alive and authoritative for domain jule-indsamling.dk
    DNS server ns2.netopcom.dk[86.58.173.15] is alive and authoritative for domain jule-indsamling.dk

    What package are you using for DNS?
    Have you got any errors in the Control Panel monitor tab?
     
  5. Niels

    Niels New Member

    Im running latest ispconfig and myDNS on Ubuntu 9.10

    In Monitor it shows that myDNS is running.
     
  6. mhpcomputerservices

    mhpcomputerservices Member HowtoForge Supporter

    On the console.
    Code:
    netstat -tap
    What is the output?
     
  7. Niels

    Niels New Member

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:smtp *:* LISTEN 6132/master
    tcp 0 0 *:https *:* LISTEN 27290/apache2
    tcp 0 0 localhost:10024 *:* LISTEN 6405/amavisd (maste
    tcp 0 0 localhost:10025 *:* LISTEN 6132/master
    tcp 0 0 *:mysql *:* LISTEN 5977/mysqld
    tcp 0 0 localhost:spamd *:* LISTEN 1081/spamd.pid
    tcp 0 0 *:http-alt *:* LISTEN 27290/apache2
    tcp 0 0 *:www *:* LISTEN 27290/apache2
    tcp 0 0 *:tproxy *:* LISTEN 27290/apache2
    tcp 0 0 86.58.173.15:domain *:* LISTEN 29207/mydns
    tcp 0 0 localhost:domain *:* LISTEN 29207/mydns
    tcp 0 0 *:ftp *:* LISTEN 7928/pure-ftpd (SER
    tcp 0 0 *:ssh *:* LISTEN 842/sshd
    tcp 0 0 localhost:56838 localhost:mysql ESTABLISHED 25499/amavisd (ch15
    tcp 0 0 localhost:mysql localhost:56838 ESTABLISHED 5977/mysqld
    tcp 0 0 localhost:56834 localhost:mysql ESTABLISHED 25489/amavisd (ch16
    tcp 0 52 86.58.173.15:ssh s83-179-9-205.cus:63714 ESTABLISHED 29103/sshd: adminis
    tcp 0 0 localhost:mysql localhost:56834 ESTABLISHED 5977/mysqld
    tcp6 0 0 [::]:imaps [::]:* LISTEN 7496/couriertcpd
    tcp6 0 0 [::]:pop3s [::]:* LISTEN 7553/couriertcpd
    tcp6 0 0 [::]:pop3 [::]:* LISTEN 7524/couriertcpd
    tcp6 0 0 [::]:imap2 [::]:* LISTEN 7466/couriertcpd
    tcp6 0 0 localhost:domain [::]:* LISTEN 29207/mydns
    tcp6 0 0 [::]:ftp [::]:* LISTEN 7928/pure-ftpd (SER
    tcp6 0 0 [::]:ssh [::]:* LISTEN 842/sshd
    tcp6 0 0 86.58.173.15%32191:pop3 h55eb1828.dkkovbr:57352 TIME_WAIT -
    tcp6 0 0 86.58.173.15%32191:pop3 h55eb1828.dkkovbr:57351 TIME_WAIT -
     
  8. mhpcomputerservices

    mhpcomputerservices Member HowtoForge Supporter

    I don't have anything like the above which is making me wonder if there is a configuration issue or possibly just a DNS record problem.

    Try the following and see if you get any errors
    Code:
    /etc/init.d/mydns stop
    /etc/init.d/mydns start
    Is the server hostname set correctly
    Code:
    hostname
    hostname -f
    Can you post screenshots of your DNS configuration?

    How did you setup the server? Was it using the howtoforge guide?
     
  9. BorderAmigos

    BorderAmigos New Member

    Is "ns1.netopcom.dk" on your computer or at your domain registrar? If at the registrar do you have A records there pointing to the IP of "jule-indsamling.dk"?
     
  10. Niels

    Niels New Member

    It working now :)

    Thank for your help. I dont know what I did but I stopped the dns and started it again...

    :)
     
  11. mhpcomputerservices

    mhpcomputerservices Member HowtoForge Supporter

    Good news :D
     

Share This Page