iRedMail + OpenLDAP + Roundcubemail... on iRedOS

Discussion in 'HOWTO-Related Questions' started by bluegrass, Nov 11, 2010.

  1. bluegrass

    bluegrass New Member

    Hi, I dunno if this is the right place to ask, but this is the scenario.

    I have a running mail server which was installed/configured using "iRedOS-0.6.0: Open Source Mail Server With Postfix, Dovecot, Amavisd, ClamAV, SpamAssassin, RoundCube" tutorial, since August 2010. Yesterday, I found out that the mail server can't be accessed and upon checking some hardware problem was encountered on the Logical Volume of the harddisk, and it wouldn't boot. I tried repairing it using the fsck manually, and after the repair it did boot. I tested it by accessing the mail thru http and it was also successful. But when I tried sending an email using the roundcubemail, I get the error on SMTP. I also checked mail.log, only to find out that all emails coming in to the server were not sent to the recipients email boxes instead errors where found. I didn't have much time to look for the main reasons of the error, and instead setup a new mail server still using the same tutorial, and yes it is now up and running.

    My problem now is how can I move copies of the old emails of the users from the previous setup to the new setup. I have a cron job running on the previous setup to copy the mail boxes to a backup data server every 6 hours, and these are the mails I wanted to copy to the new setup.

    One way I was able to do is to forward the mails to the same user using mutt, but this would take some time. And how bout the sent mails, how can I copy them to the new setup?:(
  2. ZhangHuangbin

    ZhangHuangbin New Member

    iRedMail/iRedOS uses Maildir format of mailbox, you can simply copy users' mailboxes to /var/vmail/vmail1/.

    Also, it's better to ask iRedMail/iRedOS related questions in it's official forum:
  3. bluegrass

    bluegrass New Member

    Hi Zhang, yes I tried this one by just simple copying it, but it seems that it didn't work, when I log in to the roundcubemail, it doesn't push thru... i mean, I don't get logged in successfully...

Share This Page