iRedMail: Build A Full-Featured Mail Server With LDAP, Postfix, RoundCube, Dovecot, C

Discussion in 'HOWTO-Related Questions' started by bentman78, Apr 16, 2009.

  1. bentman78

    bentman78 New Member

    Having a problem during the install. I get this error:
    dovecot-sieve-1.1.6-9.el5.i386 from iRedMail has depsolving problems
    --> Missing Dependency: dovecot >= 1.1 is needed by package dovecot-sieve-1.1. 6-9.el5.i386 (iRedMail)
    Error: Missing Dependency: dovecot >= 1.1 is needed by package dovecot-sieve-1.1 .6-9.el5.i386 (iRedMail)


    Any help is appreciated.
     
  2. topdog

    topdog HowtoForge Supporter

    Well you may not be able to resolve that dependency as Centos/RHEL 5 come with dovecot 1.0.x unless the script installs its own version of dovecot.
     
  3. bentman78

    bentman78 New Member

    I downloaded and installed the dovecot1.1 rpm from the dovecot site and it seemed to have worked fine.
     
  4. ZhangHuangbin

    ZhangHuangbin New Member

  5. anandx

    anandx HowtoForge Supporter

    This site loads up a blank page for me.

    Also i tried to use the mysql version. The install gets stuck on the screen where it asks for the "first virtual domain name". I re-extracted the archive, did all possible combinations, but install won't budge from that point :(
     
    Last edited: Apr 18, 2009
  6. ZhangHuangbin

    ZhangHuangbin New Member

    Did you use SecureCRT as ssh client to install iredmail remotely?

    There is a known issue while use SecureCRT to install iredmail remotely, please give putty/pietty or other ssh client a try.
     
  7. anandx

    anandx HowtoForge Supporter

    I am using terminal (on mac) to ssh to the server.
     
  8. ZhangHuangbin

    ZhangHuangbin New Member

    Havn't test mac terminal before :(
     
  9. anandx

    anandx HowtoForge Supporter

    Strange.

    I ran the script from the server console and it seems to be working fine. So it means there is something in that script which won't work properly when run from a mac terminal.app, very very strange. This is the first time ever i have come across an app which won't run on shell over ssh like this just because of a terminal running via mac. :eek:
     
  10. topdog

    topdog HowtoForge Supporter

    I could be something to do with the way mac os x handles dialog.
     
  11. eddiechen

    eddiechen HowtoForge Supporter

    hello, because I have no mac enviroment, so can not solve the bug.

    hope you can find the problem help us improve.
     
  12. bentman78

    bentman78 New Member

    Still getting the same error.
     
  13. bentman78

    bentman78 New Member

    If you have yum-priorities installed and have priorities set in your .repo files you have to disable the yum-priorities plugin then run the get script then the setup script and all works okay.
     

Share This Page