IPv6 problems

Discussion in 'Installation/Configuration' started by hostedby, May 13, 2012.

  1. hostedby

    hostedby New Member

    Hey,

    I set up an domain/DNS with IPv6 in the ispconfig admin and it worked for a while, however, now it has just disappeared.

    "puma:~# /etc/init.d/apache2 restart
    Restarting web server: apache2[Sun May 13 10:24:23 2012] [warn] NameVirtualHost 2a02:750:5::260:443 has no VirtualHosts
    ... waiting [Sun May 13 10:24:24 2012] [warn] NameVirtualHost 2a02:750:5::260:443 has no VirtualHosts"

    How can the DNS post for the IPv6 first work and than just disappear without changes in the sipconfig admin and without changes to any host files?

    And how do I get it to work again?:)

    I am offering new clients a free IPv6 so really need it to work and appreciate all suggestions.

    Kind regards/Michael
     
  2. falko

    falko Super Moderator

    It seems as if you did not define any vhosts for the IPv6 address 2a02:750:5::260.
     
  3. hostedby

    hostedby New Member

    There is maybe something in the setup I dont understand so I hope for a bit more info.

    First, the IPv6 worked and then it stopped to work.
    I have assigned the IPv6 to the web server in ISPCONFIGs IP section, and it also is on the server where I have the customer, and I assigned the IP to the Customer, I have set up the AAAA records in the DNS configuration for the Customers domain. All in ispconfig admin. This was done a week ago.

    And it worked, but without any changes, it starts to complain about missing vHost.

    It feels more like ISPCONFIG have lost the information or done some kind of automatic process that has deleted something,

    Again, it worked first without me doing anything else than described above.

    I have the manual since before but it is a bit weak for more deeper problems so that one dont give me any suggestions.

    And when I ping the domain it finds the IP:

    Looking up IPv6 address for cez.se...

    Pinging cez.se [2a02:750:5::260] with 32 bytes of data...
    Results
    count ttl (hops) rtt (ms) from
    1 160 2a02:750:5::260
    2 160 2a02:750:5::260
    3 160 2a02:750:5::260
    4 160 2a02:750:5::260
    5 161 2a02:750:5::260
    Statistics
    packets sent 5 times (ms) min 160
    received 5 100% avg 160
    lost 0 0% max 161

    So that looks ok.

    Kind regards/Michael
     
  4. falko

    falko Super Moderator

    Is the IPv6 address included in the Apache vhost configuration? I guess you selected * instead of the IPv6 address for the website in ISPConfig.
     
  5. baskin

    baskin New Member

    I have created my first ipv6 vhost.

    I have this:

    Code:
    <VirtualHost *:80>
          DocumentRoot /var/www/mydomain.tld/web
    and this:

    Code:
    <VirtualHost [2a00:7b80:3019:12::d7f3:23b9]:80>
          DocumentRoot /var/www/mydomain.tld/web
    Is this correct? Is it possible to have only the ipv6 host directive?
     
: ipsconfig, ipv6

Share This Page