Discussion in 'Installation/Configuration' started by fork, Oct 22, 2007.

  1. fork

    fork New Member

    iptables state

    iptables -A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT -v
    ACCEPT all opt -- in * out * -> state RELATED,ESTABLISHED
    iptables: Invalid argument

    kernel (conntrack and state module included in the kernel)
    iptables 1.40

    i read other people have this problem since kernel 2.6.18
    can anyone tell me where to read to solve it?
    Last edited: Oct 23, 2007
  2. rul3z

    rul3z New Member

  3. fork

    fork New Member

    thanks for the fast answer :)
    anyway these two tutorial doesn't really answer to my question. i solved it and somehow the kernel didn't compile conntrack module.

    i'e another question if is possible to answer^^
    whick kernel option is to enable to have recent match support?
    conntrack is enabled but i still get
    iptables: Invalid argument


    iptables -A INPUT -p tcp --syn -m recent --update --seconds 40 --hitcount 10 -j DROP
    iptables -A INPUT -p tcp --syn -m recent --set -j DROP

    --set when used doesn't want seconds and hit counts
    Last edited: Oct 22, 2007

Share This Page