iptables: Table does not exist (do you need to insmod?)

Discussion in 'Installation/Configuration' started by cccc, Mar 18, 2006.

  1. cccc

    cccc New Member

    hi

    I've installed shorewall firewall on debian sarge stable and I get the following:
    Code:
    # shorewall show capabilities
    Shorewall-2.2.3 Chain capabilities at ext.undostres.ch - Sam Mär 18 15:46:57 CET 2006
    
    Counters reset Sat Mar 18 14:55:30 CET 2006
    
    iptables: Table does not exist (do you need to insmod?)
    Code:
    # iptables -V
    iptables v1.2.11
    Code:
    # uname -a
    Linux mysystem 2.6.8-2-686 #1 Tue Aug 16 13:22:48 UTC 2005 i686 GNU/Linux
    
    depmod -a seems not to help.

    what's missing and howto solve this problem ?
     
  2. falko

    falko Super Moderator

    Run
    Code:
    modprobe ip_tables
    and add ip_tables at the end of /etc/modules.
     
  3. seblo

    seblo New Member

    I also do have the same problem:

    # iptables -L
    iptables v1.3.8: can't initialize iptables table `filter': Table does not exist (do you need to insmod?)
    Perhaps iptables or your kernel needs to be upgraded.

    but when trying to do "modprobe ip_tables"

    ha1:/home/slorandel # modprobe ip_tables
    FATAL: Module ip_tables not found

    I tried to modify the kernel configuration through "make menuconfig" but I always get the error, does somebody has other idea?

    thanks, Sebastien.
     
  4. falko

    falko Super Moderator

    What's the output of
    Code:
    grep -i iptables /boot/config-`uname -r`
    ?
     
  5. seblo

    seblo New Member

    here it is:

    Code:
    # grep -i iptables /boot/config-`uname -r`
    CONFIG_IP_NF_IPTABLES=y
    CONFIG_IP6_NF_IPTABLES=y
     
  6. falko

    falko Super Moderator

    iptables is built into the kernel, so that should not be the problem.

    I think you should also enable all the other iptables options in
    Code:
    make menuconfig
    and compile a new kernel.
     
  7. seblo

    seblo New Member

    Actually, it seems that my problem came from iptables installation and not from the kernel but I am not really sure, I reinstalled iptables with the following commands:

    Code:
    make KERNEL_DIR=/usr/src/linux
    make install KERNEL_DIR=/usr/src/linux
    then I recompiled my kernek with:

    Code:
    make dep
    make bzIamge
    make
    make install
    make modules
    now it is working, thank you for your help
     

Share This Page