Iptables problem

Discussion in 'Technical' started by newbie14, Apr 23, 2011.

  1. newbie14

    newbie14 New Member

    Dear All,
    I have a machine first I run this command service iptables restart
    Flushing firewall rules: [ OK ]
    Setting chains to policy ACCEPT: filter [ OK ]
    Unloading iptables modules: [ OK ]
    Applying iptables firewall rules: [ OK ]
    Loading additional iptables modules: ip_conntrack_netbios_n[ OK ]
    Next when I run this command vi /etc/sysconfig/iptables to insert new ports it gives me a blank page is this normal?
     
  2. falko

    falko Super Moderator

    What's your distribution?
     
  3. newbie14

    newbie14 New Member

    Dear Falko,
    I am using centos 5.5 but on other machine this is not a problem either.
     
  4. Jawshh

    Jawshh New Member

    newbie,

    You can't create rules by putting them in that iptables file. You create rules by typing:

    Code:
    iptables and rules here
    Looks like you don't know much about that firewall software. Why don't you use APF instead? It's based on iptables and much much easier to configure ;)

    If you really really want to use iptables, read this pretty good and informative page:
    http://en.gentoo-wiki.com/wiki/Iptables
     
  5. newbie14

    newbie14 New Member

    Dear Jawsh,
    What are APF? What the other firewall software we should know?
     

Share This Page