IPSConfig 3 Install Doesn't Change Apache

Discussion in 'Installation/Configuration' started by popsof3, Mar 17, 2012.

  1. popsof3

    popsof3 New Member

    I am setting up ISPConfig 3 for the first time on a new CentOS 5.7 server. I followed the setup tutorial to the letter, and received no errors. However, I can not pull up the login page. I purchased the manual thinking it would help, but it does nothing but point me back to the online setup tutorials.

    It seems as though the ISPConfig 3 install did not install itself into Apache. Therefore, when I try to hit http://MyIPAddress:8080, nothing is listening, so I don't get the login page.

    I confirmed this with: netstat -tapn

    tcp 0 0 127.0.0.1:10024 0.0.0.0:* LISTEN 11544/amavisd (mast
    tcp 0 0 127.0.0.1:10025 0.0.0.0:* LISTEN 11513/master
    tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 4611/mysqld
    tcp 0 0 127.0.0.1:3310 0.0.0.0:* LISTEN 11560/clamd
    tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 2350/portmap
    tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN 11593/pure-ftpd (SE
    tcp 0 0 0.0.0.0:885 0.0.0.0:* LISTEN 2399/rpc.statd
    tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 2629/cupsd
    tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 11513/master
    tcp 0 0 :::993 :::* LISTEN 11572/dovecot
    tcp 0 0 :::995 :::* LISTEN 11572/dovecot
    tcp 0 0 :::110 :::* LISTEN 11572/dovecot
    tcp 0 0 :::143 :::* LISTEN 11572/dovecot
    tcp 0 0 :::80 :::* LISTEN 11758/httpd
    tcp 0 0 :::21 :::* LISTEN 11593/pure-ftpd (SE
    tcp 0 0 :::22 :::* LISTEN 2616/sshd
    tcp 0 0 :::443 :::* LISTEN 11758/httpd
    tcp 0 2008 ::ffff:208.109.106.78:22 ::ffff:174.16.61.84:61660 ESTABLISHED 3222/sshd: snapedia


    Also, I can't find any ISPConfig configurations for Apache. I looked in /etc/httpd/conf and /etc/httpd/conf.d, and there is no "enabled sites" directory anywhere on the server.

    I tried uninstalling and reinstalling, but nothing helps.

    This sounds like the same exact problem as:
    http://www.howtoforge.com/forums/showthread.php?t=55665

    But that thread does not include any resolution.

    If I manually add a "Listen 8080" directive for Apache, I can get to the Apache "it works" page, so this doesn't seem to be a firewall issue. It really just seems like ISPConfig is not adding Apache directives, so there is no way to get to the login page.

    Anyone have advice for this problem? I'm about to give up altogether.
     
    Last edited: Mar 17, 2012
  2. falko

    falko Super Moderator

    Any errors in Apache's error log? Did you restart Apache? What's the output of
    Code:
    getenforce
    ?
     
  3. till

    till Super Moderator

    If you dont have a sites-enabled directory, then ispconfig is not installed properly. Please reinstall ispconfig by downloading the tar.gz file and running the install.php again.
     

Share This Page