IPSCONFIG 3.1 + Roundcube = not found

Discussion in 'Installation/Configuration' started by ewkilian, May 9, 2017.

  1. ewkilian

    ewkilian New Member

    Hello,
    I have install ISPConfig with different website (SSL and no SSL) and I have already install roundcube (automatic installation with ispconfig)
    But when I go on http://ip/webmail/ or http://domain_name/webmail/ I come on a page “Not found”…. I try with https same problem.
    I have see on Google that a few person have the same problem but I don’t find a solution.
    Do you want see my configuration, if you want, what file?
    Thanks you for your help.
    Ewkilian
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    try /roundcube instead of /webmail. and if you use nginx and not apache, use port 8081
     
  3. ewkilian

    ewkilian New Member

  4. ewkilian

    ewkilian New Member

    my apache2 log :
    *****.fr:8080 90.126.***.*** - - [09/May/2017:18:12:52 +0200] "GET /webmail HTTP/1.1" 404 524 "-" "Mozilla/5.0 (Windows NT 6.2; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.96 Safari/537.36"
     
  5. ewkilian

    ewkilian New Member

    hi,
    Please, Have you a idea to help me ?
    thanks you very much
     
  6. Jesse Norell

    Jesse Norell Well-Known Member

    You don't mention what OS you're using or how you installed roundcube (though I think you maybe mean you used an automatic installation script to install ispconfig, and that included rouncube?), so it's hard to say what is 'normal'. On debian 8 using the roundcube package from backports, there is a global /roundcube alias setup:
    Code:
    # grep Alias /etc/apache2/conf-enabled/roundcube.conf 
        Alias /roundcube /var/lib/roundcube
    
    So on that OS with that roundcube package, /roundcube should work on any website, whether it's http or https.

    Roundcube has a force_https config option which I believe is false by default, but that could affect the behavior, too.

    Other than that, you'd be on your own to configure access to /roundcube and setup your own /webmail if you like.
     
  7. ewkilian

    ewkilian New Member

    Hi,
    I have Debian8 with a automatique installation IPSCONFIG. Yes this install included roudcube /var/lib/roundcube/
    I have try differente configuration VHOST and now when I try the url :
    http://domaine.com/roundcube/
    Now I have a error 403 (forbidden). Before I have 404 error.
    I think that 403 is better. Do you have a idea to give access ?
    Thanks you
     
  8. Jesse Norell

    Jesse Norell Well-Known Member

    I'm not familiar with what the automatic installation sets up, does it install roundcube from a package or download source? You'd have to look through your webserver config to see what is set up; with a 404 not found error, my guess is that there is no /roundcube or /webmail alias defined, and if that's the case, maybe none of the other roundcube config is in place (setting permissions/options for the roundcube directories). Does 'grep -R roundcube /etc/apache2/' show anything at all?
     
  9. Hello,
    I don"t know the automatic setup for Roundcube, but to make it running, I have created websites for :
    webmail.mydomain.tld
    and added this apache directive (option tab) (this is for Ubuntu server):
    Code:
    DocumentRoot /var/lib/roundcube
    Nicolas
     
  10. chief

    chief Member

    Hi,
    You should be able to access your webmail / squirelmail or roundcubemail via http://mysite.com/webmail or https://mysite.com/webmail or http://you.ip.add.ress/webmail (if you have created a alias for it)
    To check if it exists edit /etc/apache2/conf-enabled/roundcube.conf and line 4 should state "Alias /webmail /var/lib/roundcube" or something like it (this is what mine states).
    On my install of debian, i used apt-get to install roundcube as per tutorial, been running ispconfig give or take 10 years.
    https://www.howtoforge.com/tutorial...4-jessie-apache-bind-dovecot-ispconfig-3-1/3/
     
  11. ahrasis

    ahrasis Active Member

    May be it is was not enabled.
     

Share This Page