Ipcop help

Discussion in 'Server Operation' started by asus, Mar 13, 2009.

  1. asus

    asus New Member

    Hello, I have had a ipcop setup for sometime now and love. I was only running a red and green network with all my desktop machines and my ispconfig server on the green interface. I have added a 3rd NIC and now running the ispconfig server on the orange interface. Here is my problem I'm no longer able to view any of my websites that I have created with isconfig it will only show the default local server which says IT WORKS. If i try all the different websites and the ip its the same page. I have been reading that ipcop has nat to nat problems is this the case ? Is there a work around ? I want to be able to view my websites using the url from the geen network
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Does this happen with official domains (i.e., where the requests go out to the Internet and then back to the webserver) and local domains (where the requests go to the ISPConfig server directly)?
     
  3. asus

    asus New Member

    yes both, and when someone from the internet views any of the websites they see the web directory
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Do users from your LAN see the same or something different?
     
  5. asus

    asus New Member

    yes the lan clients see the same, I put the server back on green and everything is fine.
     
  6. Flash

    Flash New Member

    If you changed the IP address on the server (which you probably needed to do to get it on the orange interface) your namevirtualhost directive will need to have that IP address changed aswell. I dont know how this works in ispconfig as I dont have experience with that tool, but I assume there must be an option to change the namevirtualhosts directive in ISPconfig somewhere.
     

Share This Page