IP servers changed. No communication Master > Slave

Discussion in 'Installation/Configuration' started by isotophe, Mar 12, 2015.

  1. isotophe

    isotophe New Member

    As reported here > https://www.howtoforge.com/communit...sses-existing-multiserver-installation.59275/ < years ago, the company I used to work for was planning to return the IP block they had ISPConfig running on.
    I left the job, and for a long long time nothing happened.

    So, by the end of last year, they called me asking for help, 'cause they had to return the address block until the next weekend.

    Now, they are an AS on the internet and they have their own netblocks.

    I got in touch with their current Sysadmin, we created a /28 block to put those servers, and I went on to reconfigure them.

    The Panel interface (and the Master server) is running on the primary DNS server, and it's working fine, but there is no communication between servers.
    Master does not get updated stats from slaves since the 5th of december. It isn't possible to create new SSH users, MySQL databases, or create mailboxes.

    Some data that might be useful attached.

    What can we do to troubleshoot this?


    Attached Files:

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Change the IP addresses in all ispcsrv* mysql users on the master server (the records are in several sub tables of the mysql.mysql.database, so the easiest way to do that is to use the phpmyadmin mysql user manager which will change all sub records that belong to a user.
    2) Check the hosts files of all server nodes and ensure that they contain the new addresses.
  3. isotophe

    isotophe New Member

    Thanks for your time, Till!

    Well, I've modified Users back in december. I guess everything is fine there.
    As you can see (screenshot attached), there are only 2 users matching "189.45", the first two octets of the old address block.
    But, what about all these matches inside columns_priv and tables_priv? Am I supposed to modify those too?

    As for the /etc/hosts: Double-checked them. Name to address pointing is correct.

    Attached Files:

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Test the mysql connection from slave to master. you get the username and password and hostname for the test from the /usr/local/ispconfig/server/lib/config.inc.php file on the slave. then login on the slave and use the mysql command on the shell. e.g.

    mysql -h master.yourcluster.tld -u ispcsrv1 -p

    to test the connection.
  5. maruhpro

    maruhpro New Member

    thanks Till, my hair will stop falling
    isotophe likes this.
  6. isotophe

    isotophe New Member

    Great, Till!

    ISPconfig was set to connect directly to the old master's IP address.
    It seems to be working fine now.

    Thank you very much!

Share This Page