IP not deleting when removing it from menu

Discussion in 'General' started by webguyz, Sep 22, 2014.

  1. webguyz

    webguyz Member HowtoForge Supporter

    I have Debian Wheezy with the latest patches and have checked the box to allow Network Configuration.

    I can add an IP to the server and it adds it just fine, but when I delete the IP it never removed it from the interface.

    I could have swore in the past it did remove the IP from the interface as well as add it thru ISPconfig. Am I confused or did it work that way before?

    Was moving stuff around this weekend and did not double check that the IP was really removed after having removed from ISPConfig and it was killing me trying to use that IP on another box. I ended up having duplicate IP's and that generated a little hair pulling until I realized that the ISPConfig box never released the IP so I had to modify /etc/network/interfaces manually and remove the IP.
     
    Last edited: Sep 22, 2014
  2. srijan

    srijan New Member HowtoForge Supporter

    Did you restarted the networking service after updating the IP in the /etc/networking/interfaces file

     
  3. webguyz

    webguyz Member HowtoForge Supporter

    I did after I did the manual remove from /etc/network/interfaces.

    But the question is does ISPConfig remove as well as add IP addresses when going thru ISPConfig and using Debian Wheezy as the OS with latest patches.

    Thanks!
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig should remove the IP from interfaces file. You should add a bugreport in the ispconfig bugtracker so we can check that.
     

Share This Page