Ip goes directly to webmail instead of isp3 HELP please

Discussion in 'Installation/Configuration' started by IrishDoc, Nov 1, 2012.

  1. IrishDoc

    IrishDoc New Member

    I followed the tutorial on how to setup isp3 for ubuntu 12.04lts and when I go to the ip address it shows the login screen for webmail and not isp3. I am not sure what I have done or how to fix it.
     
  2. sjswarts

    sjswarts New Member

    G'day IrishDoc,

    In the URL did you use the port that was chosen at the ISPConfig setup section of that tutorial? I believe that ISPConfig defaults to port 8080

    So if you choose SSL access type into your favourite web browser

    https://example.com:8080 or https://192.168.1.1:8080

    If you didn't choose SSL type into your favourite web browswer

    http://example.com:8080 or http://192.168.1.1:8080

    Obviously change the IP and domain to what you have set!

    Regards,
    Steven Swarts
     
  3. IrishDoc

    IrishDoc New Member

    I have it on 8080, you can see here 91.121.156.14:8080, if you just enter the ip it goes to webmail. It goes to the webmail no matter what I enter.
     
  4. sjswarts

    sjswarts New Member

    1) Please show link to tutorial you used
    2) Post contents of files:
    a) /etc/apache2/sites-available/ispconfig.vhost
    b) /etc/apache2/conf.d/squirrelmail.conf (I think its here, don't use it so it might have a different name or location)

    Regards,
    Steven Swarts
     
  5. sjswarts

    sjswarts New Member

    More specifically are you running Nginx or Apache2?
     
  6. IrishDoc

    IrishDoc New Member

  7. IrishDoc

    IrishDoc New Member

    apache2 (I believe), sorry I didn't specify that to my provider but when using the apache restart commands they worked perfectly.


    Just verified with my provider that apache2 is being used
     
    Last edited: Nov 1, 2012
  8. sjswarts

    sjswarts New Member

    What happens when you do:

    Code:
    cat /etc/apache2/conf.d/squirrelmail.conf
    that file should look like this to begin with:

    Code:
    Alias /squirrelmail /usr/share/squirrelmail
    Alias /webmail /usr/share/squirrelmail
     
  9. sjswarts

    sjswarts New Member

    Is it a VPS?
    Do you have actual root access? or did they just make you an account and add you to the sudoers file?
     
  10. IrishDoc

    IrishDoc New Member

    yes it does

    Code:
    Alias /squirrelmail /usr/share/squirrelmail
    Alias /webmail /usr/share/squirrelmail
    
    <Directory /usr/share/squirrelmail>
      Options FollowSymLinks
      <IfModule mod_php5.c>
        AddType application/x-httpd-php .php
        php_flag magic_quotes_gpc Off
        php_flag track_vars On
        php_admin_flag allow_url_fopen Off
        php_value include_path .
        php_admin_value upload_tmp_dir /var/lib/squirrelmail/tmp
        php_admin_value open_basedir /usr/share/squirrelmail:/etc/squirrelmail:/var/lib/squirrelmail:/etc/hostname:/etc/mailname:/var/spool/squirrelmail
        php_flag register_globals off
      </IfModule>
      <IfModule mod_dir.c>
        DirectoryIndex index.php
      </IfModule>
    
      # access to configtest is limited by default to prevent information leak
      <Files configtest.php>
        order deny,allow
        deny from all
        allow from 127.0.0.1
      </Files>
    </Directory>
    
    # users will prefer a simple URL like http://webmail.example.com
    <VirtualHost 91.121.156.14>
      DocumentRoot /usr/share/squirrelmail
      ServerName webmail.kustomhosting.net
    </VirtualHost>
    
    # redirect to https when available (thanks omen@descolada.dartmouth.edu)
    #
    #  Note: There are multiple ways to do this, and which one is suitable for
    #  your site's configuration depends. Consult the apache documentation if
    #  you're unsure, as this example might not work everywhere.
    #
    #<IfModule mod_rewrite.c>
    #  <IfModule mod_ssl.c>
    #    <Location /squirrelmail>
    #      RewriteEngine on
    #      RewriteCond %{HTTPS} !^on$ [NC]
    #      RewriteRule . https://%{HTTP_HOST}%{REQUEST_URI}  [L]
    #    </Location>
    #  </IfModule>
    #</IfModule>
    
     
  11. IrishDoc

    IrishDoc New Member

    actual root access, no need for me to add the 'sudo' for my commands
     
  12. sjswarts

    sjswarts New Member

    Change

    Code:
    <VirtualHost 91.121.156.14>
    to

    Code:
    <VirtualHost 91.121.156.14:80>
     
  13. sjswarts

    sjswarts New Member

    Make sure to run

    Code:
    /etc/init.d/apache2 restart
    What we could do to eliminate the possibility of squirrelmail being the problem (which I think it is - something wrong in your squirrelmail.conf) we can just remove that link.

    Do this:

    Code:
    rm /etc/apache2/conf.d/squirrelmail.conf
    That will remove the link and then run:

    Code:
    /etc/init.d/apache2 restart
    Then check if you can access ISPConfig
     
  14. IrishDoc

    IrishDoc New Member

    OK. after removing the mail link it worked. What do you think it might be in the conf of squirrelmail?
     
  15. sjswarts

    sjswarts New Member

    Before you removed the link did you change the squirrelmail.conf to reflect my previous post?

    Change

    Code:
    <VirtualHost 91.121.156.14>
    to

    Code:
    <VirtualHost 91.121.156.14:80>
    The issue I believe is the webmail.example.com virtualhost. If its not because you forgot to add the port behind the IP then something else is missing or miss configured.

    To re-add the link do this:

    Code:
    cd /etc/apache2/conf.d/
    ln -s ../../squirrelmail/apache.conf squirrelmail.conf
    /etc/init.d/apache2 reload
     
  16. IrishDoc

    IrishDoc New Member

    Thanks for all your help. The problem was in the port and I was able to reload the webmail link.
     

Share This Page