IP dissapears

Discussion in 'General' started by bobpit, Oct 27, 2013.

  1. bobpit

    bobpit New Member

    I enter the IP address (in the [IPv4-Address] field), I click away and the IP address dissapears.

    All I want to do is enable SSL for the particular site.

    I am at this url:

    I have only one client (myself) and only one site. The IP address I want to set is (same as in the url):

    Is this a bug, or I am doing something silly?
  2. Quaxth

    Quaxth New Member

    How you do it, via ISPConfig or from server SSH Terminal/Shell?
  3. bobpit

    bobpit New Member

    via ISPConfig version

    The server has Ubuntu 12.04, if it matters.
    Last edited: Oct 27, 2013
  4. Quaxth

    Quaxth New Member

    AFAIK 192.xxx.xxx.xxx are private network IP's and not public network IP's

    Have you try to use localhost:[port] or[port]?

    Port 8080 may be is used by your Modem/Router!! Mine is using 8080 for remote connection in Router and I'd set the IP therefore to 8088 which just works fine.

    Check your hosts file:
    vi /etc/hosts
    Should looks like this:
    Code:	localhost.localdomain	localhost   server.mydomain.com	server
    # The following lines are desirable for IPv6 capable hosts
    ::1     localhost ip6-localhost ip6-loopback
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    I use Debian Wheezy, which differs a bit from Ubuntu and I never used Ubuntu at all!!

    That said, you may need to check your config files from server and set all correctly. The easiest way for that is to install WinSCP (is freeware) on Windows desktop and connect by SSH to the server. It let you open the config files directly and also let you change the settings. You could also Copy and Paste to the sever or to the PC.
    Last edited: Oct 27, 2013
  5. bobpit

    bobpit New Member

    The domain name is www.surf-anonymous.info and the IP address given to me by the host (VPS host) is The browser will take you to the same site either you type or www.surf-anonymous.info in the address bar. So I guess this makes a public IP.

    I just tried I got the error: "The connection was reset - The connection to the server was reset while the page was loading."

    I am sorry, I am not sure what you mean. You mean to enter them in the address bar? Ok, I just tried www.localhost.com:8080/. Nothing happens, I get error "server not found: Firefox can't find the server at www.localhost.com".

    This is the content of my HOSTS file:
    Code: localhost.localdomain localhost
    # Auto-generated hostname. Please do not remove this comment. server1.surf-anonymous.info  server1
    ::1 localhost.localdomain localhost
    I use FileZilla (FTP client) and SSH-putty. I use both windows and ubuntu from my desktop. I have no problem accessing my server. My problem is to know what exactly to change. I am rather new to servers/unix and this is the reason I selected ISPConfig to do the management.
    Last edited: Oct 27, 2013
  6. Quaxth

    Quaxth New Member

    OK, as I wrote, Ubuntu differs from Debian a bit.

    I could access ISPConfig on your server:

    So, that should work for you as well. Same as above happens if I use: https://surf-anonymous.info:8080/

    Question: have you created an A record for the Sub server1?

    How I see it from my site in Thailand, your system works.

    For to use SSL, you'll need to create the SSL Certifcate first and install that. Read the ISPConfig Manual and you'll find How To.......!

    Sorry for my late answer, I was looking the Indian GP on Internet TV!!
  7. bobpit

    bobpit New Member


    I can also access https://surf-anonymous.info:8080/. It is the https://surf-anonymous.info/ that does not work.

    To tell you the truth, I am not sure. Months ago I had set it yp with Namecheap.com. Later the VPS was moved.

    I am not that good with DNS/Ip etc. Are there also clear instructions in the manual for this?

    The first step is to CHECK the SSL box, which I did and then set the IP. The IP disappears when I click away.

    I have bought the SSL, have the key etc. I just need to put thm in ISPConfig.
  8. Quaxth

    Quaxth New Member

    If you use Namecheap.com:

    In that case, you've to create to correct Record, mainly A Record at namecheap.com and also create the Sub Domain, hostname: server1, for your IP and Domain name there.

    You have to do that from your account at namecheap.com, log on to there, go to Manage Domains, click your Domain, on left under Host Management click on All Host Records.

    Under IP ASDDRESS/URL type your IP (not URL) for both 1 & 2 and choose A (Address) for both. Under SUB-DOMAIN SETTINGS Type server 1 --> your IP Address and chose A (Address). If you have more Subdomains, place them there. Under TTL type for every entry 1800

    Save all. Need up to 24h for to propagate but could be ready after 4h++.

    If you look further down that page, there also the setting for Mail. If you use User simplified, you just need to key in for HOST: mail; for Mailserver IP: your IP; for Mail Type: MXE; for MX PREF: 10; TTL: 1800

    In ISPConfig, do NOT create any DNS Zone, if you have, delete them.

    In Server Config it should looks like:


    The IP Address under Server Config is the internal (LAN) IP of your server and NOT the public IP!!

    Under Server IP Address, didn't key in anything!

    Your SSL has to be placed under Sites -->Websites, click on your domain name if you'd placed them already, if not click on Add new website and keyi the credential of your Website/Domain. There you'll also need to key in under SSL the Certificate data's!

    Hope that helps.
    Last edited: Oct 27, 2013
  9. Quaxth

    Quaxth New Member

    I checked your IP with nslookup:


    Your IP isn't found over the Internet, so I checked again with your Domain name and that's found:


    So, your domain is registered by namecheap and also the nameserver run there. That you have now to clear and set correctly. As I wrote already, keep in mind that it could need up to 24h for the new settings to propagate.
  10. bobpit

    bobpit New Member

    Thank you VERY MUCH for the very detailed instructions.

    I had done this A record procedure months ago and namecheap verified for me it was correct. I will try to do it again, according to your instructions.

    Question: Is there a diagnostic that can tell me if it is working properly and where the fault lies?

    If it is easy for you, is there a VERY simple explanation/tutorial for this, I mean what all these mean and how they work together. I do not understand them and this makes me very prone to making foolish mistakes.
  11. Quaxth

    Quaxth New Member

  12. Quaxth

    Quaxth New Member

    I'm new to Linux as well, had learned quite a bit over last few weeks and still going on with learning.

    The some tools which are very usefull for to check that special the Domain setting etc. are correct and working. One of the for to fully check Domain is: http://www.intodns.com/surf-anonymous.info




    Than, one of the most needed is done using the Command Prompt (CMD) in Windows, or like I do, use Windows Power Shell for it, is the use of the NSLOOKUP Command.

    In Windows Power Shell just type: nslookup [enter], set query=all [enter]
    type your IP or Domain name [enter] and you'll get the basic needed infos right the way.

    Hope that this helps you too!
  13. bobpit

    bobpit New Member

    I browsed the results and I think I understand 20-30% of them. I have studied Computer Science, I go to tutorials and wikipedia and still the explanations are too technical for me.

    You wouldn't know of a VERY simple tutorial for these concepts?
  14. Quaxth

    Quaxth New Member

    I'm very sorry but I've to disappoint you with that!! This is something which you mainly get known while using -->asking for explanation -->reading -->testing listen crazy but the fastest way is learning by doing!

    Forum's are a very good place for to get infos, so and sooooooo! On technical forums, Noobs or Newbies will be very disappointed in many way while they didn't understanding what those "Experts" are talking about! There not so much of those "Teachers" who didn't had forgotten that they also was one day ago start learning the same things from ground zero! And than there's is the language barrier! Native English speakers didn't like to accepting that Non-Native Speakers have problems with understanding or finding the right wording! And, and, and!!

    Don't be ashamed for to ask for what you didn't understand or know. You'll get an answer, maybe not directly, so, ask again till you get the answer. It's not liked by many people, but what way you have? Not get angry, or lose your face as we Asians say, it's not worth, just ask again.

    Regarding your problem, may you'll have to wait till tomorrow, till the staff is back working. This is an German site and it looks like that the staff is "bound" to there fixed working hour's 8h a day and 5 days a week! And there seems to be only 2 staff members with an excellent knowledge on this site, as I see till now. I'm just a 1 month member of this forum.

    So, please wait till tomorrow and look out for till of falko.

  15. bobpit

    bobpit New Member


    I did those. The namecheap supporter verified they are correct.

    (I inserted this image but it does not show: http://postimg.org/image/4vutqwgbh/

    Are you sure?

    I did setup the server1 subdomain. The following takes you to ISPConfig:

    This is still not working:

    I do not need mail.

    I will work on the rest later. Thank you
    Last edited: Oct 27, 2013
  16. bobpit

    bobpit New Member

    I asked the VPS host and could not help me with the "internal" IP. So I put there the public IP. Actually the old settings were weird, they gave me error of invalid IPs.

    I changed the IP Address, Gateway, Nameservers and Hostname. This is how it looks now (does not let me post images): http://postimg.org/image/hpgh0zjql/

    Strangely, I still cannot enter and save the IP address under Sites-> Domain -> IPv4-Address.
  17. Quaxth

    Quaxth New Member

    I was thinking you host your Server at your home/office. If you hosted your system somewhere in an DataCenter, that the whole thing are different. If you host at your own home/office than something is wrong.

    From what I see in that picture, the Gateway is your Modem/Router and that Servers IP is the static LAN IP of your Server! The public IP normally is not the LAN IP at the same time.

    For me it looks like that the "public" IP you use for your server, is only working because of installed Dynamic DNS for your system, maybe done by Namecheap.

    As I wrote already, wait for the ISPConfig staff to be back at work, which will not before 8am German time

    And for to shorten the time of those who try to help, please summarize the Structure, settings and other details of your system so it's directly understandable whet the helper has to dealing with.
  18. bobpit

    bobpit New Member

Share This Page