IP and DNS setup help needed

Discussion in 'Installation/Configuration' started by samy, May 18, 2009.

  1. samy

    samy New Member

    Good morning everyone,

    I installed a fresh server with ISPCONFIG2; I am willing to host my personel sites on it,I am getting an IP that i do not know how to configure on my PC yet, I am confused what to choose:

    1- using a nameserver ns.mydomaine.tld or
    2- using the IP : xx.xx.xxx.xxx and point my domains to it.

    I need some one to help me which one to choose and how to completely configure the nameserver and the IP step by step since i am newbie.

    Thx in advance,
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Do you want to run your own nameservers (you need at least two), or do you host your DNS records somewhere else (e.g. at your domain registrar)?
     
  3. samy

    samy New Member

    Dear Falko,
    I have two ip's and i assigned them to one domain i have with enom;
    ns1.mydomain.com and ns2.mydomain.com. see the problem is i do not know how to connect to this server using these IP's i only connect to the local IP:192.168.xxx.xx.
    but how to configure the main ip to the system, what are config files i need to change and how.
    I apreciate you help Falko.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    You must create A records for ns1.mydomain.com and ns2.mydomain.com at the registrar, and then you can use ns1 and ns2 as the nameservers when you register a new domain.
     
  5. samy

    samy New Member

    Dear Falko,
    I did these steps my big problem is that my nameservers and domains are not pinging, Do i need to change config files on the system,i did not change any all i did was pointing the ip to the local one on the router. Also in ispconfig i put the nameserver under ISPManager/server/settings/.
     
  6. falko

    falko Super Moderator ISPConfig Developer

  7. samy

    samy New Member

    Thank you for the tutorial Falko, I followed all the steps but my sites are always pointing to "Apache HTTP Server Test Page powered by CentOS".
    What is the solution,
    Thank you for your assistance.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Is your server behind a router?
     
  9. samy

    samy New Member

    Hi Till,

    Yes my server is behind a router.

    On the /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf the document roots are :
    Document Root /var/www/web11/web for xxx1.com
    Document Root /var/www/web10/web for xxx2.net
    but when i type ant site, it goes to : Document Root /var/www/

    Thank you for your help.
     
  10. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf, and what's the output of
    Code:
    ifconfig
    ?
     

Share This Page