Ip address missing at website configuration

Discussion in 'General' started by nvl-it-solutions, Jan 22, 2021.

  1. nvl-it-solutions

    nvl-it-solutions New Member

    I've got some strange issue going on.
    Recently I migrated my master ISPConfig server to a new server.
    Afterwards I changed the config to match the new ip address and added the required SQL users for the slave servers.
    I was able to join the master without an issue, the same with brand new servers.

    Now when I create a website, I'm able to select all ip addresses available on the slave server.
    After clicking on OK the configuration is saved and the website is available.
    However when I browse to another section in ISPConfig and return to the website, the ip addresses are missing and are replaced with *. For some reason I can't select and find them there. When I go to ISPConfig settings and check the server ip addresses they are all there.
    Is there some settings I'm not thinking of or do I need to change something in the database manually?
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    How was migration done?
    Did you replace IP address in all necessary places?
    grep -r the ip address in /etc. The ISPConfig GUI as ip settings in the System server settings.
     
  3. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Enable HTTP NameVirtualhost for the IP addresses you want to use for that under System -> Server IP addresses.
     
    nvl-it-solutions likes this.
  4. nvl-it-solutions

    nvl-it-solutions New Member

    Seems that solves my issue.
    Is this a new feature since I don't recognize that option?
    In the past all ip addresses were always available without enabling that option.
    This would mean I need to adjust that setting for all ip addresses.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    No, it exists since the first ISPConfig 3 versions.

    That's right, but the Ip should not be sued and selected anymore today, that's why it's hidden. It's better when you use * for all sites instead, there are only very rare occasions where it makes sense to select the IP, e.g. when you have a dedicated IP address for each website and client.
     
  6. nvl-it-solutions

    nvl-it-solutions New Member

    Ok I'll keep that in mind.
    Right now I'm selecting a specific IP because I run the websites on the server's internal ip address because I use a proxy server in front of them to save on public IPv4 addresses. Next to the internal ip address the server also has an IPv6 public ip address. When a customer asks for a dedicated IPv4 address I add it to the server and run the website on both IPv4 and IPv6 public ip address without the proxy server.
     
  7. luckyjack

    luckyjack New Member

    I faced with similar issue some time ago. I started using ultra fast VPN VeePN to hide my ip and protect my privacy online. That's convy. Luckily it doesn't cost a lot but provide a high level of security.
     
    Last edited: Feb 12, 2021

Share This Page