IP address / domain name settings during install

Discussion in 'Installation/Configuration' started by SurfingAlien, Jan 31, 2006.

  1. SurfingAlien

    SurfingAlien New Member

    Hi All!

    This type of question probably is asked many times, but I have trouble finding the answers that make things clear to me. I hope someone can help me with this. Below is my setup, but I have some issues accessing ISPConfig from the Internet (slow page buildups, page errors etc... If anyone can point out errors I made I would appreciate this...

    My setup:

    Static IP address: (this address is assigned to my modem-router)
    The hostname assigned by my ISP for this address: belgarion.xs4all.nl

    I have an internal network: 192.168.1.x /
    My ISPConfig box has been configured with IP address

    I've set up a DMZ that will forward all incoming traffic on to my ISPConfig box

    ISPConfig box: SuSe Linux 10.0 + ISPConfig, installed according to The Perfect Setup.

    During installation of Linux I've set the host & domain name to belgarion.xs4all.nl (don't know if that's a smart idea :) )

    During installation of ISPConfig I've set the host name to belgarion.xs4all.nl, but later changed that to in the config.inc.php file

    $go_info["server"]["server_url"] = "";

    (at least I think that's what I've done...)

    This was due to speed issues / page errors connecting to ISPConfig's control panel connectiong from my laptop ( From there, everything works now...

    Thanks in advance, and if I left out information, please ask!

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You will have to change the variable $go_info["server"]["server_url"] back to the URL of your server. The URL must be accessible from inside and outside your network. If you have problems to access the URL from inside your network (laptop), you can add the internal IP and URL of your server to the hosts file on your laptop.
  3. SurfingAlien

    SurfingAlien New Member

    Additional info

    Hi All!

    I just changed the ispcong.inc.php file to use the original https://belgarion.xs4all.nl:81 setting instead of the internal IP address.

    This seems to correct the page errors / slowness, connecting to "https://belgarion.xs4all.nl:81" from the Internet. I keep having the same problems if I try to use the url of one of the domains I'm hosting ("https://r-l-p.nl:81"), but that does not bother me. This might even be by design, but I'm not sure...

    This however, does not solve the issues connecting to the ISPConfig box from within my network... any thoughts on that???


  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You can access the controlpanel only from one URL, the one you defined in the config file. The controlpanel is not build to be accessed from other URL's.
  5. SurfingAlien

    SurfingAlien New Member

    Hi Till,

    This clears up a lot of my confusion! Thanks!

    One other question: Does my configuration make sense? I was not sure if it was a good idea to give my ISPConfig box the same host.domainname as the host.domainname for my static public IP address. It was the only thing I could think of to make sure sent SMTP messages had a "backtrace - able" host.domain name...

    Thanks again!

  6. falko

    falko Super Moderator ISPConfig Developer

    To the outside world it looks as if your ISPConfig server is belgarion.xs4all.nl because it is on the IP address so you can use this hostname for your ISPConfig box (but it shouldn't already be in use by another system).

Share This Page