IP addition to ISPConfig won't launch site

Discussion in 'Installation/Configuration' started by midcarolina, Oct 2, 2011.

  1. midcarolina

    midcarolina New Member


    I am using a single server system for all servers (db, mail, etc.). I have a block of public IPs, so there is no port forwarding behind a LAN. I added another available IP to ISPConfig 3. Steps:

    System >> Server IP addresses >> Add new IP....Success

    Checked ISPConfig db for new IP.....success

    Restarted Apache....success IP recognized

    Added new site...won't launch. Did a reverse lookup and IP is recognized. DNS records...double, triple checked - all accurate. Put EXACT same file system and database on original IP....site launched in under 5 minutes.
  2. falko

    falko Super Moderator ISPConfig Developer

    Do you see the IP in the output of
  3. midcarolina

    midcarolina New Member

    Hey Falko,

    I should have mentioned that previously, because the ISPConfig manual does say to check ifconfig after completion, so I did. No, it was not there. Any way I can manually add it?

    I tried adding it to /etc/hosts , and ifconfig still only showed the original IP. Again, if this helps, the 5 block of public IPs all use the same DNS, Netmask, Gateway, etc (same provider) They actually only differ with ending #

    146, 147, 148, 149, and 150

    (Using it to add a validated SSL, and the original IP is using one, which, by the way, ISPConfig was super easy to create and install a validated SSL!)
    Thanks a ton!
  4. falko

    falko Super Moderator ISPConfig Developer

    On Debian/Ubuntu, you must modify /etc/network/interfaces. On Fedore/CentOS, I think you can run
    to add an IP address.
  5. midcarolina

    midcarolina New Member

    I forgot about this. I believe you are correct.

    Thanks Falko
  6. midcarolina

    midcarolina New Member


    Just curious to see if you know this. Didn't want to take the risk. (Out of my expertise).

    For adding the new IP to ISPConfig 3, for it to show-up in:

    # ifconfig

    You are on the right path. Here is my question / concern. I am currently running IP XXX.XX.XX.123 on eth0. In:

    # system-config-network I can add another device (eth1), but this means adding another ethernet card to the motherboard, correct? Or can a second domain be comma separated in eth0? (Similar to adding DNS IPs during the install process). Will either / or confuse Linux or ultimately Apache? I don't mind adding another ethernet card if necessary. Two IP's on this server is ample. If someone else needs an SSL, I'll have to fork out for the shared SSL.

    I hope I made sense? Thanks
  7. midcarolina

    midcarolina New Member

    Solution for Redhat / Fedora Multiple IPs w/ ISPC


    I was having difficulty adding multiple IPs to ISPConfig 3 using Fedora 14 64 bit on a single server system (serverx.whatever.com) serves everything.

    Anyway, there is one ethernet card running eth0. Here are the steps that worked for me: Bind multiple IP addresses to eth0

    [root@ server root] # cd /etc/sysconfig/network-scripts/
    [root@ server network-scripts] # cp ifcfg-eth0 ifcfg-eth0:0

    This copies the configuration of eth0 to an alias eth0:0

    [root@ server network-scripts] # more ifcfg-eth0

    (Shows contents of eth0 configuration)

    [[email protected] network-scripts] # vi ifcfg-eth0:0

    Shows contents of new alias directory for eth0:0 (A mirror of eth0)

    Here you change the contents of two items only:

    Change DEVICE=eth0 to DEVICE=eth0:0
    Change IPADDR=xx.xx.xx.12 to IPADDR=xx.xx.xx.13 (or other new ip)

    Next, restart the network

    [[email protected] network-scripts] # service network restart

    Finally, run the # ifconfig command to see if the loopback is running and your new IP is listed as eth0:0

    This can be done for Redhat Linux multiple times, changing eth0:0 to


    Hope this was understood and helpful!

Share This Page