ioncude loader not working with additional php version 5.4

Discussion in 'ISPConfig 3 Priority Support' started by pawan, Sep 17, 2016.

  1. pawan

    pawan Member HowtoForge Supporter

    Following this guide - How To Use Multiple PHP Versions (PHP-FPM & FastCGI) With ISPConfig 3 (Ubuntu 12.04 LTS)
    link -
    I have installed php 5.4.45, which is working fine.
    Then I have installed ioncube loader as suggested in the guide and added the line in php.ini

    zend_extension = /opt/phpfcgi-5.4.45/lib/php/extensions/no-debug-non-zts-20100525/
    Note: - In my installation there is no folder under /opt/phpfcgi-5.4.45/lib/php/ as extensions/no-debug-non-zts-20100525 so I have created those folders.
    Again there is a ext folder in the path /opt/phpfcgi-5.4.45/include/ext.
    I also tried to create a folder ioncube and copied the file there and modified the path in php.ini
    but it didn't help.

    What I am doing wrong?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The folder is not so important, just ensure that is in that folder and that you added the ioncube line as first line in the php.ini file. Do you get an error when you run:

    /opt/phpfcgi-5.4.45/bin/php --version

    or does ioncube show up as module in the version details.
  3. pawan

    pawan Member HowtoForge Supporter

    Okay Till must have skipped some steps while replacing the guide from 5.4.12 to 5.4.45.
    I have installed fresh as it is in the guide with 5.4.12 and in that ioncube is working fine.

Share This Page