ioncube problems

Discussion in 'Installation/Configuration' started by raenk, May 6, 2015.

  1. raenk

    raenk New Member

    I'm going crazy trying to enable ioncube. My head won't go anymore.

    Here's my php -v output
    PHP 5.5.9-1ubuntu4.9 (cli) (built: Apr 17 2015 11:44:57)
    Copyright (c) 1997-2014 The PHP Group
    Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies
    with XCache v3.1.0, Copyright (c) 2005-2013, by mOo
    with Zend OPcache v7.0.3, Copyright (c) 1999-2014, by Zend Technologies
    with XCache Optimizer v3.1.0, Copyright (c) 2005-2013, by mOo
    with XCache Cacher v3.1.0, Copyright (c) 2005-2013, by mOo
    with XCache Coverager v3.1.0, Copyright (c) 2005-2013, by mOo

    I've tried adding zend_extension = /usr/lib/php5/20121212/ioncube_loader_lin_5.5.so to the very first line to every php.ini file (apache2, cgi, fpm and cli). Nothing works.

    Adding the line only to the apache php.ini file will throw error that apache didn't start within 20 seconds and in the logs I keep finding that the loader should have been loaded first (I did, the very first line of the ini file).
    Adding the line only to the cgi php.ini file will throw 500 error for ISPconfig. Apache will work fine, but no ioncube of course.

    Obviously the library is where it should be. I've searched and searched and all I can find is different problems or incomplete solutions.
     
  2. chico11mbit

    chico11mbit Member HowtoForge Supporter

    Try to disable OPcache. In my case i cannot do a clean installation of different CMS without disabling opcache.

    individual php entries:
    opcache.enable=0
     
  3. gOOvER

    gOOvER Member

    the problem is xcache, not opcache. I had same Problems. You must purge xcache. ;)

    see:
    Code:
    [email protected]:~# php -v
    PHP 5.6.7-1 (cli) (built: Mar 24 2015 12:30:15)
    Copyright (c) 1997-2015 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies
        with the ionCube PHP Loader + Intrusion Protection from ioncube24.com v5.0.4, Copyright (c) 2002-2015, by ionCube Ltd.
        with Zend OPcache v7.0.4-dev, Copyright (c) 1999-2015, by Zend Technologies
    [email protected]:~#
    
    edit: btw use latest 5.0.4 Version of ioncube loaders. ;)

    With installed and enabled xcache, you get following error.

    Code:
    [email protected]:~# php5enmod xcache
    [email protected]:~# php -v
    PHP Fatal error:  [ionCube Loader] The Loader must appear as the first entry in the php.ini file in Unknown on line 0
    [email protected]:~#
    
    It seems, xcache have a bug ;)

    @till - Maybe you remove xcache from perfect server setup guide or add a warning, that ioncube 5.x.x not working with xcache and break Server :)
     
    Last edited: May 10, 2015
  4. gOOvER

    gOOvER Member

    Latest Ioncube loaders v5.0.7 are compatible with xcache :)

    Code:
    [email protected]:~# php -v
    PHP 5.6.7-1 (cli) (built: Mar 24 2015 12:30:15)
    Copyright (c) 1997-2015 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies
        with XCache v3.2.0, Copyright (c) 2005-2014, by mOo
        with the ionCube PHP Loader + Intrusion Protection from ioncube24.com (disabled) v5.0.7, Copyright (c) 2002-2015, by ionCube Ltd.
        with Zend OPcache v7.0.4-dev, Copyright (c) 1999-2015, by Zend Technologies
        with XCache Optimizer v3.2.0, Copyright (c) 2005-2014, by mOo
        with XCache Cacher v3.2.0, Copyright (c) 2005-2014, by mOo
        with XCache Coverager v3.2.0, Copyright (c) 2005-2014, by mOo
    
     

Share This Page