Ioncube Loader installation problem on debian 9

Discussion in 'HOWTO-Related Questions' started by adamjedgar, Sep 21, 2018.

  1. adamjedgar

    adamjedgar Member

    Cannot load the ionCube PHP Loader - it was built with configuration API320160303,NTS, whereas running engine is API320170718,NTS
    PHP 7.2.9-1+0~20180910100512.5+stretch~1.gbpdaac35 (cli) (built: Sep 10 2018 10:05:13) ( NTS )


    so i downloaded the wizard and used that to run on server with the following output...

    ionCube Loader Wizard
    Loader Installed
    The ionCube Loader version 10.2.4 for PHP 7.2 is already installed and encoded files should run without problems.


    My understanding is that one must choose the correct version of ioncube loader for php version on server...trouble is, my server has 4 php versions (5.6, 7.0,7.1,7.2).

    ok so how do i sort this?
     
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    install ioncube-loader for all php-versions? use a central place for ioncube like /usr/local/ioncube and put something like 00-ioncube.ini into the extensions-dir for the php-version with this content: zend_extension = /usr/local/ioncube/ioncube_loader_lin_VERSION.so
     
  3. adamjedgar

    adamjedgar Member

    yes that was the solution...i stumbled across it yesterday and it worked immediately.
     

Share This Page