ioncube issues

Discussion in 'Suggest HOWTO' started by kkonline, Sep 6, 2008.

  1. kkonline

    kkonline New Member

    I have a script encoded with ioncube
    but on my script it shows

    Site error: the file /var/www/web1/classes/setupclass.php requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator.

    although in php.ini i have mentioned
    zend_extension=/usr/local/lib/ioncube/ioncube_loader_lin_5.2.so
    in the first line

    in the php.ini other refernce to szend is
    ; Enable compatibility mode with Zend Engine 1 (PHP 4.x)
    zend.ze1_compatibility_mode = Off


    echo phpinfo() mentions
    Code:
    Variables
    _SERVER["argc"]	0
    _ENV["PATH"]	/usr/local/bin:/usr/bin:/bin
    _ENV["PWD"]	/usr/local/lib/ioncube
    
    Environment
    Variable	Value
    PATH 	/usr/local/bin:/usr/bin:/bin
    PWD 	/usr/local/lib/ioncube
    LANG 	C
    SHLVL 	1
    _ 	/usr/sbin/apache2

    What can be done in order to run the encoded script
     
  2. falko

    falko Super Moderator

    Do you use the correct php.ini?
    Does /usr/local/lib/ioncube/ioncube_loader_lin_5.2.so exist?
     
  3. kkonline

    kkonline New Member

    yes the .so file exists in that path and i have verified the php.ini using the phpinfo() function
     
  4. falko

    falko Super Moderator

    What's the output of
    Code:
    ls -la /usr/local/lib/ioncube/
    ?
     
  5. kkonline

    kkonline New Member

    drwxr-sr-x 2 root staff 4096 Sep 6 15:40 .
    drwxrwsr-x 4 root staff 4096 Sep 6 17:53 ..
    -rwxr-xr-x 1 501 users 982084 Jul 4 2007 ioncube_loader_lin_5.2.so
    -rwxr-xr-x 1 501 users 1034212 Jul 4 2007 ioncube_loader_lin_5.2_ts.so


    the above is the output
     
  6. falko

    falko Super Moderator

    Do you use a 32 or 64bit OS, and is the IonCube loader for 32/64bit?
     

Share This Page