ioncube - ISPConfig 3 Ubuntu 11.10 X64

Discussion in 'Installation/Configuration' started by Tastiger, Apr 22, 2012.

  1. Tastiger

    Tastiger New Member

    after updating my server from X32 to X64 I have noticed that once I install ioncube it will show up as active on the main domain (server1.XXXX) - however it does not show up as active on any sites created via ISPConfig.

    Therefore what I have done is copied /etc/php5/apache2/php.ini and pasted it into the Custom php.ini settings of the sites created via ISPConfig (see attached image.)

    Question is have I done this correctly or is there a simpler method to get my php.ini to replicate onto any sites created via ISPConfig?

    [​IMG]
     
  2. falko

    falko Super Moderator

    How did you activate ioncube for the main domain?
     
  3. till

    till Super Moderator

    The correct way to install ioncube is to create file ioncube.ini in the directory /etc/php5/conf.d/which contains the load command for the zend extension. Then restrt apache and ioncube is active in all sites.

    What you did above is not recommended and not nescessary. If you want to use the php.ini field for a site, then add there only the values that differ from the main php.ini and do not add a full copy of the php.ini as you did.
     
  4. Tastiger

    Tastiger New Member

    Thanks guys for pointing me in the right direction.

    I had originally set up ioncube by adding

    PHP:
    [ionCube]
    zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.3.so
    to \etc\php5\apache2\php.ini - perhaps now I should edit the file again and take out the reference?
     
    Last edited: Apr 23, 2012
  5. till

    till Super Moderator

    You can leave it as it is now as you modified already all websites manually. But I recommend that you edit the websites again and remove the duplicate content in the php.ini fields. If a website does not require any custom php.ini settings, then the php.ini field should be empty. If a site needs custom settings, then only the custom settings should be in that field and not the whole php.ini.
     

Share This Page