invalidd used storage space

Discussion in 'Installation/Configuration' started by caffetin, Nov 6, 2007.

  1. caffetin

    caffetin New Member

    Not sure if that caused the problem but I noticed after I have updated the ispconfig that the used storage space on every site displays 0. the general information about the used disk space is ok, and from time to time I get notices if some user is nere or has exceeded their limit.
    what could be the problem?
     
    Last edited: Nov 6, 2007
  2. falko

    falko Super Moderator ISPConfig Developer

    Have you tried to set $go_info["server"]["sudo_du_enabled"] to 1 in /home/admispconfig/ispconfig/lib/config.inc.php?
     
  3. caffetin

    caffetin New Member

    yes, I also added the ispconfig user to the sudoers file so that it can acces the /usr/bin/du
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Hm, do you have a screenshot of this?
     
  5. caffetin

    caffetin New Member

    screenshot

    here it is.
    I have also noticed that the du command does not give me any useful info for example:

    [[email protected] /]# du -h /home/web19/
    [[email protected] /]#

    does not output anything
     

    Attached Files:

  6. falko

    falko Super Moderator ISPConfig Developer

    That's strange. Only for that directory, or for any directory?
    What's the output of
    Code:
    ls -la /home/web19
    ?
     
  7. caffetin

    caffetin New Member

    thats what is bottering me that the same output is given for every directory I try to check with the du command.

    [[email protected] ~]# ls -la /home/web19/
    total 56
    drwxr-xr-x 8 web19_ad web19 4096 Nov 6 09:23 .
    drwxr-xr-x 108 root root 12288 Nov 9 11:47 ..
    -rw------- 1 web19_ad web19 24 Nov 6 09:23 .forward
    -rw-rw-r-- 1 root web19 26 Nov 12 04:02 .htpasswd
    -rw-r--r-- 1 root root 450 Nov 6 09:23 .procmailrc
    lrwxrwxrwx 1 root root 43 Nov 6 09:23 .spamassassin -> /home/web19/user/web19_admin/.spamassassin/
    lrwxrwxrwx 1 root root 44 Nov 6 09:23 .vacation.cache -> /home/web19/user/web19_admin/.vacation.cache
    lrwxrwxrwx 1 root root 36 Nov 6 09:23 Maildir -> /home/web19/user/web19_admin/Maildir
    drwxrwxr-x 2 web19_ad web19 4096 Jul 20 13:54 cgi-bin
    drwxr-xr-x 3 web19_ad web19 4096 Nov 2 00:30 log
    drwxrwxrwx 2 web19_ad web19 4096 Jul 20 13:49 phptmp
    drwxr-xr-x 2 web19_ad web19 4096 Jul 20 13:49 ssl
    drwxr-xr-x 3 web19_ad web19 4096 Jul 20 13:50 user
    drwxrwxr-x 13 web19_ad web19 4096 Sep 12 04:05 web
     
    Last edited: Nov 12, 2007
  8. falko

    falko Super Moderator ISPConfig Developer

    The output looks ok.

    For any directory, even if it wasn't created by ISPConfig?
     
  9. caffetin

    caffetin New Member

    I haven't tried that before, it looks like the du works ok with the folders that the system created but it dosn't work with the folders that ispconfig created.
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Which filesystem type do you use for the home partition?
     
  11. caffetin

    caffetin New Member

    ext3
    here is the complete fstab if it can provide some usefull information

    # This file is edited by fstab-sync - see 'man fstab-sync' for details
    /dev/md2 / ext3 defaults,usrquota,grpquota 1 1
    /dev/md0 /boot ext3 defaults 1 2
    none /dev/pts devpts gid=5,mode=620 0 0
    none /dev/shm tmpfs defaults 0 0
    none /proc proc defaults 0 0
    none /sys sysfs defaults 0 0
    /dev/md1 swap swap defaults 0 0
    /dev/fd0 /media/floppy auto pamconsole,exec,noauto,managed 0 0
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Then I have really no Idea what may cause this. ISPConfig uses the standard commands like mkdir etc. to create directories and I had never seen before that the du command if executed as root can not show the size of the directories.

    Maybe you can try to check your harddisk with chkdisk.
     

Share This Page