Invalid URL

Discussion in 'Installation/Configuration' started by Tripple, Nov 7, 2007.

  1. Tripple

    Tripple New Member

    One site gives this error:

    Invalid URL

    The requested URL "/", is invalid.
    Reference #9.d08782c3.1194472615.0

    I restarted apache but this didn't help. Any idea what's going on?
    Server is running ISPConfig 2.2.18, Debian 4
     
  2. Tripple

    Tripple New Member

    After a complete reboot the error remains. Other sites are working perfect.

    All of a sudden, the site was back. I hate this. I like to know what was going on.

    Could it be DNS?
     
    Last edited: Nov 8, 2007
  3. edge

    edge Active Member Moderator

    For sure not a DNS problem. It looks more like some PHP problem to me
     
  4. Tripple

    Tripple New Member

    Since this was a live server I tried a lot of things. I was sending a mail to a user following this with tail -f. After the mails were delivered, the site was back. But I can't believe sending a mail can fix a webserver.
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Are you using rewrite rules in Apache? I guess it could be a problem in that area.
     
  6. Tripple

    Tripple New Member

    This is a Debian 4 perfect install with ISPconfig 2.2.18
    There's one subdomain with a forward to that site. I don't know how ISPConfig handles this. With a rewrite rule?

    Other sites on the same server were running fine.
     
  7. falko

    falko Super Moderator ISPConfig Developer

    What's in Vhosts_ispconfig.conf?
    Are there any .htaccess files with rewrite rules in that web site?
     
  8. Tripple

    Tripple New Member

    There are no .htaccess files in that site.
    In Vhosts_ispconfig.conf there are quite a few rewrite rules for that site.
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Canb you post that file?
     
  10. Tripple

    Tripple New Member

    Untill now the site is running fine. Here's the config file for that site:

    <VirtualHost 87.238.161.104:80>
    ServerName www.academie-gestript.be:80
    ServerAdmin webmaster@academie-gestript.be
    DocumentRoot /var/www/web2/web
    ServerAlias blog.academie-gestript.be academie-gestript.be
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ErrorLog /var/www/web2/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Alias /error/ "/var/www/web2/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web2/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web2/user/$1/web/$3
    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^blog\.academie-gestript\.be [NC]
    RewriteRule ^/(.*) http://www.academie-gestript.be/$1 [L,R]
    RewriteCond %{HTTP_HOST} ^academie-gestript\.be [NC]
    RewriteRule ^/(.*) http://www.academie-gestript.be/$1 [L,R]
    </VirtualHost>
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    What is the exact URL that you neter in the browser when you get the error message:

     
  12. Tripple

    Tripple New Member

    That's an easy question. All!
    Even pages that are not on the server. Like this: http://this.domain.com/test.php
     
  13. falko

    falko Super Moderator ISPConfig Developer

  14. Tripple

    Tripple New Member

    I know. While I was working on a solution the site came back by itself.
    I hate situations like that because it might happen again.

    I was thinking about a DNS problem. When trying to reach the broken site, I followed the log files with tail -f and couldn't see my requests.
     
  15. Tripple

    Tripple New Member

    It's back.

    Invalid URL

    The requested URL "[no URL]", is invalid.
    Reference #9.d08782c3.1195417232.0
     
  16. Tripple

    Tripple New Member

    This must be a local problem.
    When I use a proxy server or with anonymouse.org the site is OK.

    However, in the error log I can see:
    [Sun Nov 18 21:34:05 2007] [error] an unknown filter was not added: PHP
     
  17. Tripple

    Tripple New Member

    Fixed

    After restarting my workstation the problem was solved. Strange.
     
  18. darksoulpk68

    darksoulpk68 New Member

    Hello, I am sorry, some people might be mad about bringing back this Old post but I have found the solution.

    1. Try to flushdns in your computer first.
    2. Click on Start
    3. Click on Run
    4. Type cmd and click on OK button
    5. In the command prompt windows, type ipconfig /flushdns and hit enter button.
    6. Try to browse the website again.
    Source: Dotnetflish Blogspot.
     

Share This Page