"Invalid tmp-dir path." In a server settings, fresh install

Discussion in 'Installation/Configuration' started by gosha, Feb 17, 2018.

  1. gosha

    gosha New Member

    I have a fresh install, CentOS.
    When I go to System, Server Config and without any changes trying to switch server config's tab from Server any other, for example, Male, I'm getting the error "Invalid tmp-dir path."

    Backup tmp directory for zip is /tmp

    I have tried to install new ISPConfig with Ubuntu using HOWTO from a ispconfig.org website but have the same result.

    Where to look for a solution?

    Attached Files:

    Last edited: Feb 18, 2018
  2. gosha

    gosha New Member

    Fresh installation with Ubuntu do the same. Please help
  3. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    Please change line 194 in /usr/local/ispconfig/interface/web/admin/form/server_config.tform.php from
    'regex' => '/^\/[a-zA-Z0-9\.\-\_\/]{5,128}$/',
    'regex' => "/(|^\\/{1,2}(?:[\\w-]+[.]?\\/?){5,128})$/",
    gosha likes this.
  4. florian030

    florian030 ISPConfig Developer ISPConfig Developer

  5. gosha

    gosha New Member

    Thank you!
  6. tegralens

    tegralens New Member

    I am still getting this error even after changing the above line. This is also a fresh install.
    Any ideas ?
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Enter /var/tmp into that field or update ISPConfig to git-stable branch.

Share This Page