Internet not working on New Release Kali — 2020.1

Discussion in 'Installation/Configuration' started by Moeez Hussain, Feb 24, 2020.

  1. Moeez Hussain

    Moeez Hussain New Member

    I have installed virtual box 6.1 and downloaded Kali Linux the latest release 2020.1 , ethernet seems to be connected but internet is not working. (This was with ping and a web browser.)

    I'm using Bridging mode but I also checked NAT option, where the VM gets a different IP scheme.

    My LAN subnet is 172.16.10.xxx. My host gets 172.16.10.59 and my guest gets 172.16.10.92. Guest and host are using the same DNS servers, provided through DHCP. Host works. Guest doesn't.
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Compare network settings in host and guest.
    Code:
    ip a
    ip r
    More info with command
    Code:
    man  ip
    Did you test ping with IP-number or hostname? Try pinging with IP-number your router. Then try
    Code:
    ping -c 3 8.8.8.8
     
  3. Moeez Hussain

    Moeez Hussain New Member

    i tried
    ping -c 3 8.8.8.8 and ping -c2 1.1.1.1 both are not working
     
  4. Moeez Hussain

    Moeez Hussain New Member

    here is the output

    [email protected]:~# ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 08:00:27:99:02:77 brd ff:ff:ff:ff:ff:ff
    inet 172.16.10.92/25 brd 172.16.10.127 scope global dynamic noprefixroute eth0
    valid_lft 681676sec preferred_lft 681676sec
    inet6 fe80::a00:27ff:fe99:277/64 scope link noprefixroute
    valid_lft forever preferred_lft forever
    [email protected]:~# ip r
    default via 172.16.10.1 dev eth0 proto dhcp metric 100
    172.16.10.0/25 dev eth0 proto kernel scope link src 172.16.10.92 metric 100
     
  5. Moeez Hussain

    Moeez Hussain New Member

    default gateway can be pinged

    [email protected]:~# ping 172.16.10.1
    PING 172.16.10.1 (172.16.10.1) 56(84) bytes of data.
    64 bytes from 172.16.10.1: icmp_seq=1 ttl=255 time=2.07 ms
    64 bytes from 172.16.10.1: icmp_seq=2 ttl=255 time=1.16 ms
    64 bytes from 172.16.10.1: icmp_seq=3 ttl=255 time=5.03 ms
    64 bytes from 172.16.10.1: icmp_seq=4 ttl=255 time=1.37 ms
    64 bytes from 172.16.10.1: icmp_seq=5 ttl=255 time=1.03 ms
    64 bytes from 172.16.10.1: icmp_seq=6 ttl=255 time=2.85 ms
    64 bytes from 172.16.10.1: icmp_seq=7 ttl=255 time=2.85 ms
    ^C
    --- 172.16.10.1 ping statistics ---
    7 packets transmitted, 7 received, 0% packet loss, time 6010ms
    rtt min/avg/max/mdev = 1.031/2.337/5.031/1.302 ms
     
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    How are those outputs different from the output of same commands on the host?
     
  7. Moeez Hussain

    Moeez Hussain New Member

    internet on Host Machine works with proxy do we have to configure proxy here also ?
     
  8. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Certainly.
     
  9. Moeez Hussain

    Moeez Hussain New Member

    these are from the VM only
     
  10. Moeez Hussain

    Moeez Hussain New Member

    CAN YOU HELP ME WITH THAT
     
  11. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    CAN YOU MAYBE SHOW THE OUTPUT OF COMMANDS i ASKED FOR?
     
  12. Moeez Hussain

    Moeez Hussain New Member

    I think I did posted the responses is there any left ?
     
  13. Moeez Hussain

    Moeez Hussain New Member

    being I newbie can you help me in man ip command with exact command
     
  14. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Good thing we stopped shouting.
    If you can ping your router with IP-number but not IP-numbers outside your network, the problem is with the router. Just to make sure, the first command succeeds but the second answers 100% packet loss?
    Code:
    ping -c 3 172.16.10.1
    ping -c 3 8.8.8.8
    Since you are using bridged ethernet, you must have same networks settings on guest as are on host (except IP-number is different). You wrote you must use proxy on host, try using proxy on guest also. As for how that is done, I have no idea what kind of proxy is on your network. How did you set it up on the host? What kind of proxy and what for is it?
     
  15. Moeez Hussain

    Moeez Hussain New Member

    my host machine is getting the IP from same router/switch as my VM is (via DHCP) but host is working fine, we need proxy on browsers only which work with simple authentication i.e. username and password. the proxy firewall is from bluecoat ( Symantec product )
     
  16. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    You have not said what is the Operating system on the host. Is it some Linux distribution?
    I think Kali linux is for network security testing, maybe it has some extra secure settings that prevent it from working in a usual network?
    Can you ping the IP-number of your name server? Try looking in file /etc/resolv.conf what tihe IP is.
    Are you sure the default router is the correct one? If you can ping the router but routing does not work it looks like the router is not doing its job. Maybe it has some configuration to allow only certain hosts to access the Internet?
    I have to leave office now, so no more answers today.
     
  17. Moeez Hussain

    Moeez Hussain New Member

    I am working on windows 10 on Host machine having virtual box version 6 , I have put manual proxy in browser its start working I mean browsing but I can not able to ping via command line . is it important to update the Kali Linux and it will be done via command line

    thanks for your support you can reply me when ever you have time or may be some one else will join the conversation also till then take care and have a nice day / evening
     
  18. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Did not get to leave just yet, and it occurred to me: does ping 8.8.8.8 work on the host computer?
     
  19. Moeez Hussain

    Moeez Hussain New Member

    no it did not work
     
  20. Moeez Hussain

    Moeez Hussain New Member

    while using these commands
    $ export http_proxy="PROXY_SERVER:pORT"
    $ export https_proxy="PROXY_SERVER:pORT"
    $ export ftp_proxy="PROXY_SERVER:pORT"

    the only challenge is that its if you have special character you need to use ASCII Code how i determine what ASCII Code is against plus sign (+) –
     

Share This Page