Internal server error with Fast-CGI and file upload > 15M

Discussion in 'Installation/Configuration' started by rkleivel, Aug 17, 2011.

  1. rkleivel

    rkleivel New Member

    Hi!
    I'm hosting a couple of drupal6 sites on ISPconfig3. Unfortunately I run into an issue when trying to upload files larger than around 15 MB in drupal - getting Error 500, Internal server error. The apache2 log does not log anything when this happens.
    Uploading smaller files works fine.
    Switching from Fast-CGI to SuPHP solves the problem, but then I run into another stupid drupal issue... CGI: same problem.

    Thankful for any hints :)

    Roald
     
  2. pititis

    pititis Member

    Hi,

    how did you set upload_max_filesize in php.ini for your drupal sites?

    By default upload_ max_filesize is small. (e.g 2MB in Ubuntu)

    Cheers
     
  3. rkleivel

    rkleivel New Member

    Yes, of course :) As said this works perfectly fine if switching to SuPHP in ISPconfig - which of course it wouldn't if the setting you mention wasn't increased from default...
    Thanks anyway!
    Roald
     
  4. pititis

    pititis Member

    Try this:

    http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html#fcgidmaxrequestlen

    Cheers
     
  5. rkleivel

    rkleivel New Member

  6. falko

    falko Super Moderator ISPConfig Developer

    Yes, I think so.
     
  7. falko

    falko Super Moderator ISPConfig Developer

Share This Page