Internal Server Error Immediately After Installation.

Discussion in 'Installation/Configuration' started by researcher7, Mar 25, 2013.

  1. researcher7

    researcher7 New Member

    (If this was answered before, please excuse this message and point me to where I can read about it)

    Please help, I am about to lose my sanity.
    Just finished installing ISPConfig 3 following the steps in this article.

    Not a single error or problem encountered during the install.
    Now going to https://myipaddress:8080
    I see "Internal Server Error" messages.

    Here is what I can collect from logs and file versions.

    [/var/log/httpd]# tail -f error_log
    suexec policy violation: see suexec log for more details
    [Mon Mar 25 05:16:12 2013] [warn] [client x.x.x.x] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [Mon Mar 25 05:16:12 2013] [error] [client x.x.x.x] Premature end of script headers: index.php

    [/var/log/httpd]# tail -f suexec.log
    [2013-03-25 05:17:21]: uid: (32014/ispconfig) gid: (32017/ispconfig) cmd: .php-fcgi-starter
    [2013-03-25 05:17:21]: command not in docroot (/var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter)

    [/var/log/httpd]# suexec -V
    -D AP_DOC_ROOT="/home"
    -D AP_GID_MIN=100
    -D AP_HTTPD_USER="apache"
    -D AP_LOG_EXEC="/var/log/httpd/suexec.log"
    -D AP_SAFE_PATH="/usr/local/bin:/usr/bin:/bin"
    -D AP_UID_MIN=500
    -D AP_USERDIR_SUFFIX="public_html"

    root@www [/var/log/httpd]# httpd -V
    Server version: Apache/2.2.15 (Unix)
    Server built: May 16 2012 22:32:26
    Server's Module Magic Number: 20051115:24
    Server loaded: APR 1.3.9, APR-Util 1.3.9
    Compiled using: APR 1.3.9, APR-Util 1.3.9
    Architecture: 64-bit
    Server MPM: Prefork
    threaded: no
    forked: yes (variable process count)
    Server compiled with....
    -D APACHE_MPM_DIR="server/mpm/prefork"
    -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
    -D HTTPD_ROOT="/etc/httpd"
    -D SUEXEC_BIN="/usr/sbin/suexec"
    -D DEFAULT_PIDLOG="run/"
    -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
    -D DEFAULT_LOCKFILE="logs/accept.lock"
    -D DEFAULT_ERRORLOG="logs/error_log"
    -D AP_TYPES_CONFIG_FILE="conf/mime.types"
    -D SERVER_CONFIG_FILE="conf/httpd.conf"

    This is
    CentOS release 6.4 x64

    Thank you for your time and assistance.
  2. researcher7

    researcher7 New Member

    I tried everything in the book. Removed and completely re-installed. Still get the same error.

    Thank you.
  3. researcher7

    researcher7 New Member

    Never mind. Just saw the sticky notice. I'll move this post to the right forum, but the initial link sends to here.

Share This Page