internal messages problem with postfix

Discussion in 'Server Operation' started by ozymate, Mar 17, 2008.

  1. ozymate

    ozymate New Member

    Hello,

    After a server crash, I re-installed postfix, cyrus-imapd, amavisd-new, spamassassin on a Centos 5.1 box. But, now mail system behaves somewhat different.

    There is no problem with mail receiving/sending from/to internet.

    Before the crash, mail system used to sent internal messages to [email protected]. But now, I can't receive internal messages as it tries to send them to [email protected]. I used the same postfix, cyrus-imapd, amavisd-new, /etc/aliases conf files from the previous setup.

    Must be a configuration issue I overlook. Could anybody tell me what to check?

    Best wishes,
    Mufit

    main.cf:
    mydomain = example.com
    myhostname = server.example.com
    mydestination = example.com ...

    amavisd.conf
    $mydomain = 'example.com';
    $myhostname = 'server.example.com';
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/hosts?
     
  3. ozymate

    ozymate New Member

    The problem was turned out existing sendmail package on the server.

    All the communications for internal messages start with a line similar to the following,

    Mar 18 13:08:57 server sendmail[24537]: m2IB8vTH024537: from=root, size=61064, class=0, nrcpts=1, msgid=<[email protected]>, relay=root@localhost
    Mar 18 13:08:57 server postfix/smtpd[24513]: connection established

    After introduction of "server.example.com" as the "domain name" by sendmail, postfix uses it all the way long.

    Removing sendmail fixed the problem.

    Falko, thank you for your excellent Howtos and kind reply.

    Best wishes,
    Mufit
     

Share This Page